summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/audio_4_channel_mic/Makefile
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2021-08-30 14:42:11 -0400
committerGitHub <noreply@github.com>2021-08-30 14:42:11 -0400
commiteb3d9b26cbda2d2612f11eb39843b221224f1fa7 (patch)
tree7a514b4d21dd0d2a324a5e1313a144f26bf20799 /tinyusb/examples/device/audio_4_channel_mic/Makefile
parentee9cc322d301631c9ff0751d9bed717c6492b6a5 (diff)
parentb0845cc3f1a8234a30c980eccf10e44765e4e105 (diff)
downloadSensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.tar.gz
Sensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.tar.bz2
Sensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.zip
Merge pull request #9 from joeycastillo/usb-refactor
USB refactor / Makefile simplification
Diffstat (limited to 'tinyusb/examples/device/audio_4_channel_mic/Makefile')
-rwxr-xr-xtinyusb/examples/device/audio_4_channel_mic/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/tinyusb/examples/device/audio_4_channel_mic/Makefile b/tinyusb/examples/device/audio_4_channel_mic/Makefile
new file mode 100755
index 00000000..5a455078
--- /dev/null
+++ b/tinyusb/examples/device/audio_4_channel_mic/Makefile
@@ -0,0 +1,12 @@
+include ../../../tools/top.mk
+include ../../make.mk
+
+INC += \
+ src \
+ $(TOP)/hw \
+
+# Example source
+EXAMPLE_SOURCE += $(wildcard src/*.c)
+SRC_C += $(addprefix $(CURRENT_PATH)/, $(EXAMPLE_SOURCE))
+
+include ../../rules.mk