summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/board_test/Makefile
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
commit39a5c822a2a2e798e2e39ff8a98b7af84253026c (patch)
treefa157c98d3aea0d4f996e4415aa2a7ad1093ac05 /tinyusb/examples/device/board_test/Makefile
parentc9e00b83bbdcb05058806d915ec4fff3cf4e596f (diff)
downloadSensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.gz
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.bz2
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.zip
add tinyusb
Diffstat (limited to 'tinyusb/examples/device/board_test/Makefile')
-rwxr-xr-xtinyusb/examples/device/board_test/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tinyusb/examples/device/board_test/Makefile b/tinyusb/examples/device/board_test/Makefile
new file mode 100755
index 00000000..b65575ce
--- /dev/null
+++ b/tinyusb/examples/device/board_test/Makefile
@@ -0,0 +1,18 @@
+include ../../../tools/top.mk
+include ../../make.mk
+
+INC += \
+ src \
+ $(TOP)/hw \
+
+# Example source
+EXAMPLE_SOURCE += $(wildcard src/*.c)
+SRC_C += $(addprefix $(CURRENT_PATH)/, $(EXAMPLE_SOURCE))
+
+# board_test example is special example that doesn't enable device or host stack
+# This can cause some TinyUSB API missing, this hack to allow us to fill those API
+# to pass the compilation process
+CFLAGS += \
+ -D"tud_int_handler(x)= " \
+
+include ../../rules.mk