summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
commit39a5c822a2a2e798e2e39ff8a98b7af84253026c (patch)
treefa157c98d3aea0d4f996e4415aa2a7ad1093ac05 /tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt
parentc9e00b83bbdcb05058806d915ec4fff3cf4e596f (diff)
downloadSensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.gz
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.bz2
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.zip
add tinyusb
Diffstat (limited to 'tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt')
-rwxr-xr-xtinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt b/tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt
new file mode 100755
index 00000000..639dde99
--- /dev/null
+++ b/tinyusb/examples/device/cdc_msc_freertos/CMakeLists.txt
@@ -0,0 +1,22 @@
+cmake_minimum_required(VERSION 3.5)
+
+# TOP is absolute path to root directory of TinyUSB git repo
+# needed for esp32sx build. TOOD could be removed later on
+set(TOP "../../..")
+get_filename_component(TOP "${TOP}" REALPATH)
+
+include(${CMAKE_CURRENT_SOURCE_DIR}/../../../hw/bsp/family_support.cmake)
+
+# gets PROJECT name for the example (e.g. <BOARD>-<DIR_NAME>)
+family_get_project_name(PROJECT ${CMAKE_CURRENT_LIST_DIR})
+
+project(${PROJECT})
+
+# Checks this example is valid for the family and initializes the project
+family_initialize_project(${PROJECT} ${CMAKE_CURRENT_LIST_DIR})
+
+# Check for -DFAMILY=
+if(FAMILY MATCHES "^esp32s[2-3]")
+else()
+ message(FATAL_ERROR "Invalid FAMILY specified: ${FAMILY}")
+endif()