summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/hid_generic_inout/CMakeLists.txt
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2021-12-08 15:52:07 -0500
committerGitHub <noreply@github.com>2021-12-08 15:52:07 -0500
commitc0d02ceddd233ccccd4926b6eb5b6fe54771aac0 (patch)
tree88c257f6b70111b4ae09fd8518e38e9197cd2a4e /tinyusb/examples/device/hid_generic_inout/CMakeLists.txt
parentc25b6929cd4a3db9daa33738350b969ec590cd28 (diff)
parentd33d3fbd51253e3e072186a71959fdf97c8d2e75 (diff)
downloadSensor-Watch-c0d02ceddd233ccccd4926b6eb5b6fe54771aac0.tar.gz
Sensor-Watch-c0d02ceddd233ccccd4926b6eb5b6fe54771aac0.tar.bz2
Sensor-Watch-c0d02ceddd233ccccd4926b6eb5b6fe54771aac0.zip
Merge pull request #25 from willianpaixao/add-submodules
Add tinyusb as git submodules
Diffstat (limited to 'tinyusb/examples/device/hid_generic_inout/CMakeLists.txt')
m---------tinyusb0
-rwxr-xr-xtinyusb/examples/device/hid_generic_inout/CMakeLists.txt28
2 files changed, 0 insertions, 28 deletions
diff --git a/tinyusb b/tinyusb
new file mode 160000
+Subproject f8288be03f28ad7b944e6925f49422dfa39202c
diff --git a/tinyusb/examples/device/hid_generic_inout/CMakeLists.txt b/tinyusb/examples/device/hid_generic_inout/CMakeLists.txt
deleted file mode 100755
index abc4d91d..00000000
--- a/tinyusb/examples/device/hid_generic_inout/CMakeLists.txt
+++ /dev/null
@@ -1,28 +0,0 @@
-cmake_minimum_required(VERSION 3.5)
-
-include(${CMAKE_CURRENT_SOURCE_DIR}/../../../hw/bsp/family_support.cmake)
-
-# gets PROJECT name for the example (e.g. <BOARD>-<DIR_NAME>)
-family_get_project_name(PROJECT ${CMAKE_CURRENT_LIST_DIR})
-
-project(${PROJECT})
-
-# Checks this example is valid for the family and initializes the project
-family_initialize_project(${PROJECT} ${CMAKE_CURRENT_LIST_DIR})
-
-add_executable(${PROJECT})
-
-# Example source
-target_sources(${PROJECT} PUBLIC
- ${CMAKE_CURRENT_SOURCE_DIR}/src/main.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/usb_descriptors.c
- )
-
-# Example include
-target_include_directories(${PROJECT} PUBLIC
- ${CMAKE_CURRENT_SOURCE_DIR}/src
- )
-
-# Configure compilation flags and libraries for the example... see the corresponding function
-# in hw/bsp/FAMILY/family.cmake for details.
-family_configure_device_example(${PROJECT}) \ No newline at end of file