summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/sltb009a/board.mk
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2021-08-30 14:42:11 -0400
committerGitHub <noreply@github.com>2021-08-30 14:42:11 -0400
commiteb3d9b26cbda2d2612f11eb39843b221224f1fa7 (patch)
tree7a514b4d21dd0d2a324a5e1313a144f26bf20799 /tinyusb/hw/bsp/sltb009a/board.mk
parentee9cc322d301631c9ff0751d9bed717c6492b6a5 (diff)
parentb0845cc3f1a8234a30c980eccf10e44765e4e105 (diff)
downloadSensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.tar.gz
Sensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.tar.bz2
Sensor-Watch-eb3d9b26cbda2d2612f11eb39843b221224f1fa7.zip
Merge pull request #9 from joeycastillo/usb-refactor
USB refactor / Makefile simplification
Diffstat (limited to 'tinyusb/hw/bsp/sltb009a/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/sltb009a/board.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/sltb009a/board.mk b/tinyusb/hw/bsp/sltb009a/board.mk
new file mode 100755
index 00000000..e8a24d1b
--- /dev/null
+++ b/tinyusb/hw/bsp/sltb009a/board.mk
@@ -0,0 +1,47 @@
+CFLAGS += \
+ -flto \
+ -mthumb \
+ -mcpu=cortex-m4 \
+ -mfloat-abi=hard \
+ -mfpu=fpv4-sp-d16 \
+ -nostdlib -nostartfiles \
+ -D__STARTUP_CLEAR_BSS \
+ -D__START=main \
+ -DEFM32GG12B810F1024GM64 \
+ -DCFG_TUSB_MCU=OPT_MCU_EFM32GG12
+
+# mcu driver cause following warnings
+#CFLAGS += -Wno-error=unused-parameter
+
+SILABS_FAMILY = efm32gg12b
+SILABS_CMSIS = hw/mcu/silabs/cmsis-dfp-$(SILABS_FAMILY)/Device/SiliconLabs/$(shell echo $(SILABS_FAMILY) | tr a-z A-Z)
+
+DEPS_SUBMODULES += hw/mcu/silabs/cmsis-dfp-$(SILABS_FAMILY)
+DEPS_SUBMODULES += lib/CMSIS_5
+
+# All source paths should be relative to the top level.
+LD_FILE = $(SILABS_CMSIS)/Source/GCC/$(SILABS_FAMILY).ld
+
+SRC_C += \
+ $(SILABS_CMSIS)/Source/system_$(SILABS_FAMILY).c \
+ src/portable/silabs/efm32/dcd_efm32.c
+
+SRC_S += \
+ $(SILABS_CMSIS)/Source/GCC/startup_$(SILABS_FAMILY).S
+
+INC += \
+ $(TOP)/lib/CMSIS_5/CMSIS/Core/Include \
+ $(TOP)/$(SILABS_CMSIS)/Include \
+ $(TOP)/hw/bsp/$(BOARD)
+
+# For TinyUSB port source
+VENDOR = silabs
+CHIP_FAMILY = efm32
+
+# For freeRTOS port source
+FREERTOS_PORT = ARM_CM4
+
+# For flash-jlink target
+JLINK_DEVICE = EFM32GG12B810F1024
+
+flash: flash-jlink