summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/spresense/board.mk
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-08-28 12:50:18 -0400
commit39a5c822a2a2e798e2e39ff8a98b7af84253026c (patch)
treefa157c98d3aea0d4f996e4415aa2a7ad1093ac05 /tinyusb/hw/bsp/spresense/board.mk
parentc9e00b83bbdcb05058806d915ec4fff3cf4e596f (diff)
downloadSensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.gz
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.tar.bz2
Sensor-Watch-39a5c822a2a2e798e2e39ff8a98b7af84253026c.zip
add tinyusb
Diffstat (limited to 'tinyusb/hw/bsp/spresense/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/spresense/board.mk73
1 files changed, 73 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/spresense/board.mk b/tinyusb/hw/bsp/spresense/board.mk
new file mode 100755
index 00000000..a46c42bd
--- /dev/null
+++ b/tinyusb/hw/bsp/spresense/board.mk
@@ -0,0 +1,73 @@
+DEPS_SUBMODULES += hw/mcu/sony/cxd56/spresense-exported-sdk
+
+# Platforms are: Linux, Darwin, MSYS, CYGWIN
+PLATFORM := $(firstword $(subst _, ,$(shell uname -s 2>/dev/null)))
+
+ifeq ($(PLATFORM),Darwin)
+ # macOS
+ MKSPK = $(TOP)/hw/mcu/sony/cxd56/mkspk/mkspk
+else ifeq ($(PLATFORM),Linux)
+ # Linux
+ MKSPK = $(TOP)/hw/mcu/sony/cxd56/mkspk/mkspk
+else
+ # Cygwin/MSYS2
+ MKSPK = $(TOP)/hw/mcu/sony/cxd56/mkspk/mkspk.exe
+endif
+
+SERIAL ?= /dev/ttyUSB0
+
+CFLAGS += \
+ -DCONFIG_HAVE_DOUBLE \
+ -Dmain=spresense_main \
+ -pipe \
+ -std=gnu11 \
+ -mcpu=cortex-m4 \
+ -mthumb \
+ -mfpu=fpv4-sp-d16 \
+ -mfloat-abi=hard \
+ -mabi=aapcs \
+ -fno-builtin \
+ -fno-strength-reduce \
+ -fomit-frame-pointer \
+ -Wno-error=undef \
+ -Wno-error=cast-align \
+ -Wno-error=unused-parameter \
+ -DCFG_TUSB_MCU=OPT_MCU_CXD56 \
+
+# lwip/src/core/raw.c:334:43: error: declaration of 'recv' shadows a global declaration
+CFLAGS += -Wno-error=shadow
+
+SPRESENSE_SDK = $(TOP)/hw/mcu/sony/cxd56/spresense-exported-sdk
+
+SRC_C += src/portable/sony/cxd56/dcd_cxd56.c
+
+INC += \
+ $(SPRESENSE_SDK)/nuttx/include \
+ $(SPRESENSE_SDK)/nuttx/arch \
+ $(SPRESENSE_SDK)/nuttx/arch/chip \
+ $(SPRESENSE_SDK)/nuttx/arch/os \
+ $(SPRESENSE_SDK)/sdk/include \
+
+LIBS += \
+ $(SPRESENSE_SDK)/nuttx/libs/libapps.a \
+ $(SPRESENSE_SDK)/nuttx/libs/libnuttx.a \
+
+LD_FILE = hw/mcu/sony/cxd56/spresense-exported-sdk/nuttx/scripts/ramconfig.ld
+
+LDFLAGS += \
+ -Xlinker --entry=__start \
+ -nostartfiles \
+ -nodefaultlibs \
+ -Wl,--gc-sections \
+ -u spresense_main
+
+$(MKSPK): $(BUILD)/$(PROJECT).elf
+ $(MAKE) -C $(TOP)/hw/mcu/sony/cxd56/mkspk
+
+$(BUILD)/$(PROJECT).spk: $(MKSPK)
+ @echo CREATE $@
+ @$(MKSPK) -c 2 $(BUILD)/$(PROJECT).elf nuttx $@
+
+# flash
+flash: $(BUILD)/$(PROJECT).spk
+ @$(TOP)/hw/mcu/sony/cxd56/tools/flash_writer.py -s -c $(SERIAL) -d -b 115200 -n $<