summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/main.yml20
-rw-r--r--.gitignore15
-rw-r--r--Doxyfile2
-rwxr-xr-xapps/Sensor Watch Buzzer Demo/make/.gitignore1
-rwxr-xr-xapps/accelerometer-test/make/.gitignore1
-rwxr-xr-xapps/beats-time/make/.gitignore1
-rwxr-xr-xapps/buzzer-test/make/.gitignore1
-rwxr-xr-xapps/spi-test/make/.gitignore1
-rwxr-xr-xapps/starter-project/make/.gitignore1
-rw-r--r--make.mk3
10 files changed, 31 insertions, 15 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
new file mode 100644
index 00000000..f07c5db0
--- /dev/null
+++ b/.github/workflows/main.yml
@@ -0,0 +1,20 @@
+name: Build
+
+on: [pull_request, push]
+
+jobs:
+ build:
+ container:
+ image: ghcr.io/armmbed/mbed-os-env:latest
+ runs-on: ubuntu-latest
+ steps:
+ - name: Checkout
+ uses: actions/checkout@v2
+ - name: Compile beats-time app
+ run: make
+ working-directory: 'apps/beats-time/make'
+ - name: Upload UF2
+ uses: actions/upload-artifact@v2
+ with:
+ name: watch.uf2
+ path: apps/beats-time/make/build/watch.uf2
diff --git a/.gitignore b/.gitignore
index 4c97e2d4..6c5ca630 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,17 +1,18 @@
-.DS_Store
-*.s#*
+**/build/
*.b#*
-*.pro
-*.job
-
*.bin
+*.d
*.elf
*.hex
+*.job
*.lss
*.map
+*.o
+*.pro
+*.s#*
*.uf2
*srec
-*.o
-*.d
+.DS_Store
.vs
.vscode
+docs/ \ No newline at end of file
diff --git a/Doxyfile b/Doxyfile
index da710195..7f04a047 100644
--- a/Doxyfile
+++ b/Doxyfile
@@ -8,7 +8,7 @@ PROJECT_NAME = "Sensor Watch"
PROJECT_NUMBER = "0.0.0"
PROJECT_BRIEF = "A board replacement for the classic Casio F-91W wristwatch, powered by a Microchip SAM L22 microcontroller."
PROJECT_LOGO =
-OUTPUT_DIRECTORY = "../Sensor-Watch-Documentation"
+OUTPUT_DIRECTORY = "."
CREATE_SUBDIRS = NO
ALLOW_UNICODE_NAMES = NO
OUTPUT_LANGUAGE = English
diff --git a/apps/Sensor Watch Buzzer Demo/make/.gitignore b/apps/Sensor Watch Buzzer Demo/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/Sensor Watch Buzzer Demo/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/accelerometer-test/make/.gitignore b/apps/accelerometer-test/make/.gitignore
deleted file mode 100755
index 567609b1..00000000
--- a/apps/accelerometer-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/beats-time/make/.gitignore b/apps/beats-time/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/beats-time/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/buzzer-test/make/.gitignore b/apps/buzzer-test/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/buzzer-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/spi-test/make/.gitignore b/apps/spi-test/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/spi-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/starter-project/make/.gitignore b/apps/starter-project/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/starter-project/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/make.mk b/make.mk
index f6a37c7e..f1301733 100644
--- a/make.mk
+++ b/make.mk
@@ -20,7 +20,8 @@ else
MKDIR = mkdir
endif
-CFLAGS += -W -Wall --std=gnu99 -Os
+CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations
+CFLAGS += --std=gnu99 -Os
CFLAGS += -fno-diagnostics-show-caret
CFLAGS += -fdata-sections -ffunction-sections
CFLAGS += -funsigned-char -funsigned-bitfields