diff options
-rw-r--r-- | .github/workflows/main.yml | 20 | ||||
-rw-r--r-- | .gitignore | 15 | ||||
-rw-r--r-- | Doxyfile | 2 | ||||
-rwxr-xr-x | apps/Sensor Watch Buzzer Demo/make/.gitignore | 1 | ||||
-rwxr-xr-x | apps/accelerometer-test/make/.gitignore | 1 | ||||
-rwxr-xr-x | apps/beats-time/make/.gitignore | 1 | ||||
-rwxr-xr-x | apps/buzzer-test/make/.gitignore | 1 | ||||
-rwxr-xr-x | apps/spi-test/make/.gitignore | 1 | ||||
-rwxr-xr-x | apps/starter-project/make/.gitignore | 1 | ||||
-rw-r--r-- | make.mk | 3 |
10 files changed, 31 insertions, 15 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml new file mode 100644 index 00000000..f07c5db0 --- /dev/null +++ b/.github/workflows/main.yml @@ -0,0 +1,20 @@ +name: Build + +on: [pull_request, push] + +jobs: + build: + container: + image: ghcr.io/armmbed/mbed-os-env:latest + runs-on: ubuntu-latest + steps: + - name: Checkout + uses: actions/checkout@v2 + - name: Compile beats-time app + run: make + working-directory: 'apps/beats-time/make' + - name: Upload UF2 + uses: actions/upload-artifact@v2 + with: + name: watch.uf2 + path: apps/beats-time/make/build/watch.uf2 @@ -1,17 +1,18 @@ -.DS_Store -*.s#* +**/build/ *.b#* -*.pro -*.job - *.bin +*.d *.elf *.hex +*.job *.lss *.map +*.o +*.pro +*.s#* *.uf2 *srec -*.o -*.d +.DS_Store .vs .vscode +docs/
\ No newline at end of file @@ -8,7 +8,7 @@ PROJECT_NAME = "Sensor Watch" PROJECT_NUMBER = "0.0.0" PROJECT_BRIEF = "A board replacement for the classic Casio F-91W wristwatch, powered by a Microchip SAM L22 microcontroller." PROJECT_LOGO = -OUTPUT_DIRECTORY = "../Sensor-Watch-Documentation" +OUTPUT_DIRECTORY = "." CREATE_SUBDIRS = NO ALLOW_UNICODE_NAMES = NO OUTPUT_LANGUAGE = English diff --git a/apps/Sensor Watch Buzzer Demo/make/.gitignore b/apps/Sensor Watch Buzzer Demo/make/.gitignore deleted file mode 100755 index 3722ac63..00000000 --- a/apps/Sensor Watch Buzzer Demo/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/
diff --git a/apps/accelerometer-test/make/.gitignore b/apps/accelerometer-test/make/.gitignore deleted file mode 100755 index 567609b1..00000000 --- a/apps/accelerometer-test/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/ diff --git a/apps/beats-time/make/.gitignore b/apps/beats-time/make/.gitignore deleted file mode 100755 index 3722ac63..00000000 --- a/apps/beats-time/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/
diff --git a/apps/buzzer-test/make/.gitignore b/apps/buzzer-test/make/.gitignore deleted file mode 100755 index 3722ac63..00000000 --- a/apps/buzzer-test/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/
diff --git a/apps/spi-test/make/.gitignore b/apps/spi-test/make/.gitignore deleted file mode 100755 index 3722ac63..00000000 --- a/apps/spi-test/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/
diff --git a/apps/starter-project/make/.gitignore b/apps/starter-project/make/.gitignore deleted file mode 100755 index 3722ac63..00000000 --- a/apps/starter-project/make/.gitignore +++ /dev/null @@ -1 +0,0 @@ -build/
@@ -20,7 +20,8 @@ else MKDIR = mkdir endif -CFLAGS += -W -Wall --std=gnu99 -Os +CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations +CFLAGS += --std=gnu99 -Os CFLAGS += -fno-diagnostics-show-caret CFLAGS += -fdata-sections -ffunction-sections CFLAGS += -funsigned-char -funsigned-bitfields |