summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/build.yml3
-rw-r--r--make.mk5
-rw-r--r--movement/make/Makefile1
-rw-r--r--movement/movement_faces.h1
-rw-r--r--movement/watch_faces/complication/timer_face.c4
-rw-r--r--movement/watch_faces/complication/tuning_tones_face.c140
-rw-r--r--movement/watch_faces/complication/tuning_tones_face.h57
-rw-r--r--watch-library/shared/watch/watch_private_display.c2
-rw-r--r--watch-library/shared/watch/watch_utility.c78
-rw-r--r--watch-library/simulator/shell.html110
-rw-r--r--watch-library/simulator/watch/watch_buzzer.c2
-rw-r--r--watch-library/simulator/watch/watch_rtc.c5
12 files changed, 370 insertions, 38 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index b150afb1..6b4fc793 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -6,6 +6,9 @@ on:
branches-ignore:
- gh-pages
+env:
+ COLOR: BLUE
+
jobs:
build:
container:
diff --git a/make.mk b/make.mk
index a83108bd..955ea310 100644
--- a/make.mk
+++ b/make.mk
@@ -62,6 +62,7 @@ CFLAGS += -MD -MP -MT $(BUILD)/$(*F).o -MF $(BUILD)/$(@F).d
LDFLAGS += -mcpu=cortex-m0plus -mthumb
LDFLAGS += -Wl,--gc-sections
LDFLAGS += -Wl,--script=$(TOP)/watch-library/hardware/linker/saml22j18.ld
+LDFLAGS += -Wl,--print-memory-usage
LIBS += -lm
@@ -207,6 +208,10 @@ ifeq ($(LED), BLUE)
CFLAGS += -DWATCH_IS_BLUE_BOARD
endif
+ifndef COLOR
+$(error Set the COLOR variable to RED, BLUE, or GREEN depending on what board you have.)
+endif
+
ifeq ($(COLOR), BLUE)
CFLAGS += -DWATCH_IS_BLUE_BOARD
endif
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 64c0364f..376ee744 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -119,6 +119,7 @@ SRCS += \
../watch_faces/clock/decimal_time_face.c \
../watch_faces/clock/wyoscan_face.c \
../watch_faces/clock/minute_repeater_decimal_face.c \
+ ../watch_faces/complication/tuning_tones_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.
diff --git a/movement/movement_faces.h b/movement/movement_faces.h
index 8ece8b8d..96fc60ac 100644
--- a/movement/movement_faces.h
+++ b/movement/movement_faces.h
@@ -96,6 +96,7 @@
#include "decimal_time_face.h"
#include "wyoscan_face.h"
#include "minute_repeater_decimal_face.h"
+#include "tuning_tones_face.h"
// New includes go above this line.
#endif // MOVEMENT_FACES_H_
diff --git a/movement/watch_faces/complication/timer_face.c b/movement/watch_faces/complication/timer_face.c
index 70f250a5..8bf7cf99 100644
--- a/movement/watch_faces/complication/timer_face.c
+++ b/movement/watch_faces/complication/timer_face.c
@@ -30,7 +30,7 @@
#include "watch.h"
#include "watch_utility.h"
-static const uint16_t _default_timer_values[] = {0x200, 0x500, 0xA00, 0x1400, 0x2D02}; // default timers: 2 min, 5 min, 10 min, 20 min, 2 h 45 min
+static const uint32_t _default_timer_values[] = {0x000200, 0x000500, 0x000A00, 0x001400, 0x002D02}; // default timers: 2 min, 5 min, 10 min, 20 min, 2 h 45 min
// sound sequence for a single beeping sequence
static const int8_t _sound_seq_beep[] = {BUZZER_NOTE_C8, 3, BUZZER_NOTE_REST, 3, -2, 2, BUZZER_NOTE_C8, 5, BUZZER_NOTE_REST, 25, 0};
@@ -199,7 +199,7 @@ void timer_face_setup(movement_settings_t *settings, uint8_t watch_face_index, v
timer_state_t *state = (timer_state_t *)*context_ptr;
memset(*context_ptr, 0, sizeof(timer_state_t));
state->watch_face_index = watch_face_index;
- for (uint8_t i = 0; i < sizeof(_default_timer_values) / sizeof(uint16_t); i++) {
+ for (uint8_t i = 0; i < sizeof(_default_timer_values) / sizeof(uint32_t); i++) {
state->timers[i].value = _default_timer_values[i];
}
}
diff --git a/movement/watch_faces/complication/tuning_tones_face.c b/movement/watch_faces/complication/tuning_tones_face.c
new file mode 100644
index 00000000..a139427a
--- /dev/null
+++ b/movement/watch_faces/complication/tuning_tones_face.c
@@ -0,0 +1,140 @@
+/*
+ * MIT License
+ *
+ * Copyright (c) 2023 Per Waagø
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in all
+ * copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ */
+
+#include <stdlib.h>
+#include <string.h>
+#include "tuning_tones_face.h"
+
+/*
+
+ This face plays a tone that can be used as a reference when tuning
+ musical instrument.
+
+ - The alarm button (short press) starts and stops the tone
+ - The light button (short press) changes which note is played. The name
+ of the note is shown in the display.
+
+*/
+
+typedef struct Note {
+ BuzzerNote note;
+ char * name;
+} Note;
+
+static Note notes[] = {
+ { .note = BUZZER_NOTE_C5, .name = "C " },
+ { .note = BUZZER_NOTE_C5SHARP_D5FLAT, .name = "Db" },
+ { .note = BUZZER_NOTE_D5, .name = "D " },
+ { .note = BUZZER_NOTE_D5SHARP_E5FLAT, .name = "Eb" },
+ { .note = BUZZER_NOTE_E5, .name = "E " },
+ { .note = BUZZER_NOTE_F5, .name = "F " },
+ { .note = BUZZER_NOTE_F5SHARP_G5FLAT, .name = "Gb" },
+ { .note = BUZZER_NOTE_G5, .name = "G " },
+ { .note = BUZZER_NOTE_G5SHARP_A5FLAT, .name = "Ab" },
+ { .note = BUZZER_NOTE_A5, .name = "A " },
+ { .note = BUZZER_NOTE_A5SHARP_B5FLAT, .name = "Bb" },
+ { .note = BUZZER_NOTE_B5, .name = "B " },
+};
+
+static size_t note_count = sizeof notes / sizeof *notes;
+
+static void draw(tuning_tones_state_t *state)
+{
+ watch_display_string(notes[state->note_ind].name, 8);
+}
+
+void tuning_tones_face_setup(movement_settings_t *settings, uint8_t watch_face_index, void ** context_ptr) {
+ (void) settings;
+ (void) watch_face_index;
+ if (*context_ptr == NULL) {
+ tuning_tones_state_t *state = malloc(sizeof *state);
+ memset(state, 0, sizeof *state);
+ state->note_ind = 9;
+ *context_ptr = state;
+ }
+}
+
+void tuning_tones_face_activate(movement_settings_t *settings, void *context) {
+ (void) settings;
+ (void) context;
+}
+
+static void update_buzzer(const tuning_tones_state_t *state)
+{
+ if (state->playing) {
+ watch_set_buzzer_off();
+ watch_set_buzzer_period(NotePeriods[notes[state->note_ind].note]);
+ watch_set_buzzer_on();
+ }
+}
+
+bool tuning_tones_face_loop(movement_event_t event, movement_settings_t *settings, void *context) {
+ tuning_tones_state_t *state = (tuning_tones_state_t *)context;
+
+ switch (event.event_type) {
+ case EVENT_ACTIVATE:
+ draw(state);
+ break;
+ case EVENT_TICK:
+ break;
+ case EVENT_LIGHT_BUTTON_DOWN:
+ state->note_ind++;
+ if (state->note_ind == note_count) {
+ state->note_ind = 0;
+ }
+ update_buzzer(state);
+ draw(state);
+ break;
+ case EVENT_LIGHT_BUTTON_UP:
+ break;
+ case EVENT_ALARM_BUTTON_DOWN:
+ state->playing = !state->playing;
+ if (!state->playing) {
+ watch_set_buzzer_off();
+ } else {
+ update_buzzer(state);
+ }
+ case EVENT_ALARM_BUTTON_UP:
+ break;
+ case EVENT_TIMEOUT:
+ movement_move_to_face(0);
+ break;
+ case EVENT_LOW_ENERGY_UPDATE:
+ break;
+ default:
+ return movement_default_loop_handler(event, settings);
+ }
+
+ return !state->playing;
+}
+
+void tuning_tones_face_resign(movement_settings_t *settings, void *context) {
+ (void) settings;
+ tuning_tones_state_t *state = (tuning_tones_state_t *)context;
+
+ if (state->playing) {
+ state->playing = false;
+ watch_set_buzzer_off();
+ }
+}
diff --git a/movement/watch_faces/complication/tuning_tones_face.h b/movement/watch_faces/complication/tuning_tones_face.h
new file mode 100644
index 00000000..d6e3495e
--- /dev/null
+++ b/movement/watch_faces/complication/tuning_tones_face.h
@@ -0,0 +1,57 @@
+/*
+ * MIT License
+ *
+ * Copyright (c) 2023 Per Waagø
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in all
+ * copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ */
+
+#ifndef TUNING_TONES_FACE_H_
+#define TUNING_TONES_FACE_H_
+
+#include "movement.h"
+
+/*
+ * A DESCRIPTION OF YOUR WATCH FACE
+ *
+ * and a description of how use it
+ *
+ */
+
+typedef struct {
+ // Anything you need to keep track of, put it here!
+ bool playing;
+ size_t note_ind;
+} tuning_tones_state_t;
+
+void tuning_tones_face_setup(movement_settings_t *settings, uint8_t watch_face_index, void ** context_ptr);
+void tuning_tones_face_activate(movement_settings_t *settings, void *context);
+bool tuning_tones_face_loop(movement_event_t event, movement_settings_t *settings, void *context);
+void tuning_tones_face_resign(movement_settings_t *settings, void *context);
+
+#define tuning_tones_face ((const watch_face_t){ \
+ tuning_tones_face_setup, \
+ tuning_tones_face_activate, \
+ tuning_tones_face_loop, \
+ tuning_tones_face_resign, \
+ NULL, \
+})
+
+#endif // TUNING_TONES_FACE_H_
+
diff --git a/watch-library/shared/watch/watch_private_display.c b/watch-library/shared/watch/watch_private_display.c
index 245b20ed..c12957d9 100644
--- a/watch-library/shared/watch/watch_private_display.c
+++ b/watch-library/shared/watch/watch_private_display.c
@@ -93,7 +93,7 @@ void watch_display_character(uint8_t character, uint8_t position) {
}
if (character == 'T' && position == 1) watch_set_pixel(1, 12); // add descender
- else if (position == 0 && (character == 'B' || character == 'D')) watch_set_pixel(0, 15); // add funky ninth segment
+ else if (position == 0 && (character == 'B' || character == 'D' || character == '@')) watch_set_pixel(0, 15); // add funky ninth segment
else if (position == 1 && (character == 'B' || character == 'D' || character == '@')) watch_set_pixel(0, 12); // add funky ninth segment
}
diff --git a/watch-library/shared/watch/watch_utility.c b/watch-library/shared/watch/watch_utility.c
index 9e524762..64b3bb79 100644
--- a/watch-library/shared/watch/watch_utility.c
+++ b/watch-library/shared/watch/watch_utility.c
@@ -102,13 +102,81 @@ uint16_t watch_utility_days_since_new_year(uint16_t year, uint8_t month, uint8_t
return (is_leap(year) && (month > 2) ? 1 : 0) + DAYS_SO_FAR[month - 1] + day;
}
+// Function taken from `src/time/__year_to_secs.c` of musl libc
+// https://musl.libc.org
+static uint32_t __year_to_secs(uint32_t year, int *is_leap)
+{
+ if (year-2ULL <= 136) {
+ int y = year;
+ int leaps = (y-68)>>2;
+ if (!((y-68)&3)) {
+ leaps--;
+ if (is_leap) *is_leap = 1;
+ } else if (is_leap) *is_leap = 0;
+ return 31536000*(y-70) + 86400*leaps;
+ }
+
+ int cycles, centuries, leaps, rem;
+
+ if (!is_leap) is_leap = &(int){0};
+ cycles = (year-100) / 400;
+ rem = (year-100) % 400;
+ if (rem < 0) {
+ cycles--;
+ rem += 400;
+ }
+ if (!rem) {
+ *is_leap = 1;
+ centuries = 0;
+ leaps = 0;
+ } else {
+ if (rem >= 200) {
+ if (rem >= 300) centuries = 3, rem -= 300;
+ else centuries = 2, rem -= 200;
+ } else {
+ if (rem >= 100) centuries = 1, rem -= 100;
+ else centuries = 0;
+ }
+ if (!rem) {
+ *is_leap = 0;
+ leaps = 0;
+ } else {
+ leaps = rem / 4U;
+ rem %= 4U;
+ *is_leap = !rem;
+ }
+ }
+
+ leaps += 97*cycles + 24*centuries - *is_leap;
+
+ return (year-100) * 31536000LL + leaps * 86400LL + 946684800 + 86400;
+}
+
+// Function taken from `src/time/__month_to_secs.c` of musl libc
+// https://musl.libc.org
+static int __month_to_secs(int month, int is_leap)
+{
+ static const int secs_through_month[] = {
+ 0, 31*86400, 59*86400, 90*86400,
+ 120*86400, 151*86400, 181*86400, 212*86400,
+ 243*86400, 273*86400, 304*86400, 334*86400 };
+ int t = secs_through_month[month];
+ if (is_leap && month >= 2) t+=86400;
+ return t;
+}
+
+// Function adapted from `src/time/__tm_to_secs.c` of musl libc
+// https://musl.libc.org
uint32_t watch_utility_convert_to_unix_time(uint16_t year, uint8_t month, uint8_t day, uint8_t hour, uint8_t minute, uint8_t second, uint32_t utc_offset) {
- uint32_t year_adj = year + 4800;
- uint32_t leap_days = 1 + (year_adj / 4) - (year_adj / 100) + (year_adj / 400);
- uint32_t days = 365 * year_adj + leap_days + watch_utility_days_since_new_year(year, month, day) - 1;
- days -= 2472692; /* Adjust to Unix epoch. */
+ int is_leap;
+
+ // POSIX tm struct starts year at 1900 and month at 0
+ // https://pubs.opengroup.org/onlinepubs/9699919799/basedefs/time.h.html
+ uint32_t timestamp = __year_to_secs(year - 1900, &is_leap);
+ timestamp += __month_to_secs(month - 1, is_leap);
- uint32_t timestamp = days * 86400;
+ // Regular conversion from musl libc
+ timestamp += (day - 1) * 86400;
timestamp += hour * 3600;
timestamp += minute * 60;
timestamp += second;
diff --git a/watch-library/simulator/shell.html b/watch-library/simulator/shell.html
index 335b9534..c8da063e 100644
--- a/watch-library/simulator/shell.html
+++ b/watch-library/simulator/shell.html
@@ -37,12 +37,13 @@
.highlight { fill: #fff !important; }
#skinselect label {
display: inline-block;
- padding: 8px;
+ padding: 4px;
background-color: black;
color: white;
border-radius: 8px;
border: 2px solid #0e57a9;
outline: 4px solid black;
+ margin: 4px;
cursor: pointer;
}
#skinselect #a158wea-label {
@@ -50,13 +51,16 @@
color: black;
border-color: black;
outline-color: #b68855ff;
-
+ }
+ h2 {
+ margin: 8px 0;
+ font-size: 1em;
}
</style>
</head>
<body>
-<div style="max-width: 800px; margin: 0 auto; display: flex; flex-direction: column; align-items: center;">
+<div style="max-width: 800px; min-width: 400px; margin: 0 auto; padding: 0 1em; display: flex; flex-direction: column; align-items: center;">
<h1 style="text-align: center;">Sensor Watch Emulator</h1>
<svg xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 1271 1311" width="320">
<defs>
@@ -882,18 +886,40 @@
</g>
</g>
</svg>
- <table cellpadding="5"><tr><td id="skinselect">
- <input type="radio" id="f91w" name="skin" value="f91w" onclick="toggleSkin()" checked><label for="f91w">F-91W</label>
- <input type="radio" name="skin" id="a158wea" value="a158wea" onclick="toggleSkin()"><label id="a158wea-label" for="a158wea">A158WEA-9</label>
- </td><td><a href="https://github.com/alexisphilip/Casio-F-91W">Original F-91W SVG</a> is &copy; 2020 Alexis Philip,<br>used here under the terms of the MIT license.</td></tr></table>
-</div>
-<button onclick="getLocation()">Set location register (will prompt for access)</button>
-<br>
-<input id="input" style="width: 500px"></input>
-<button id="submit" onclick="sendText()">Send</button>
-<br>
-<textarea id="output" rows="8" style="width: 100%"></textarea>
+ <div style="display: grid; grid-template-columns: 80px 1fr; align-items: center; margin: 8px 0">
+ <h2>Skin</h2>
+ <div id="skinselect">
+ <input type="radio" name="skin" id="f91w" value="f91w" onclick="setSkin(this.value)" checked><label
+ for="f91w">F-91W</label>
+ <input type="radio" name="skin" id="a158wea9" value="a158wea9" onclick="setSkin(this.value)"><label
+ id="a158wea-label" for="a158wea9">A158WEA-9</label>
+ </div>
+
+ <h2>Volume</h2>
+ <div>
+ <input id="volume" name="volume" type="range" min="0" max="100" step="1" oninput="setVolume(this.value)" />
+ </div>
+
+ <h2>Location</h2>
+ <div>
+ <button onclick="getLocation()">Set register (will prompt for access)</button>
+ </div>
+ </div>
+
+ <div style="display: flex; flex-direction: column; width: 100%">
+ <textarea id="output" rows="8" style="width: 100%"></textarea>
+ <div style="display: flex">
+ <input id="input" placeholder="Filesystem command (see filesystem.c)" style="flex-grow: 1"></input>
+ <button id="submit" onclick="sendText()">Send</button>
+ </div>
+ </div>
+
+ <p>
+ <a href="https://github.com/alexisphilip/Casio-F-91W">Original F-91W SVG</a> is &copy; 2020 Alexis Philip, used here
+ under the terms of the MIT license.
+ </p>
+</div>
<script type='text/javascript'>
var outputElement = document.getElementById('output');
@@ -967,20 +993,52 @@
}
}
- function toggleSkin() {
- var isBlack = document.getElementById('f91w').checked;
- Array.from(document.getElementsByClassName("f91w")).forEach(
- function(element, index, array) {
- element.setAttribute('style', 'display:' + (isBlack ? 'inline':'none') + ';');
+ const validSkins = ["f91w", "a158wea9"];
+ function setSkin(chosenSkin) {
+ setLocalPref("skin", chosenSkin);
+ validSkins.forEach(function(skin) {
+ Array.from(document.getElementsByClassName(skin)).forEach(
+ function(element) {
+ element.setAttribute('style', 'display:' + (skin == chosenSkin ? 'inline':'none') + ';');
}
- );
- Array.from(document.getElementsByClassName("a158wea9")).forEach(
- function(element, index, array) {
- element.setAttribute('style', 'display:' + (isBlack ? 'none':'inline') + ';');
- }
- );
+ );
+ });
+ }
+
+ // emulator runs on localhost:8000 which could very well be used by other
+ // things, so we'll scope our localStorage keys with a prefix
+ const localStoragePrefix = "sensorwatch_";
+ function setLocalPref(key, val) {
+ localStorage.setItem(localStoragePrefix+key, val);
+ }
+ function getLocalPref(key, dfault) {
+ let pref = localStorage.getItem(localStoragePrefix+key);
+ if (pref === null) return dfault;
+ return pref;
+ }
+
+ volumeGain = 0.1;
+ function setVolume(vol) {
+ setLocalPref("volume", vol);
+ volumeGain = Math.pow(100, (vol / 100) - 1) - 0.01;
+ }
+
+ function loadPrefs() {
+ let vol = +getLocalPref("volume", "50");
+ if (isNaN(vol) || vol < 0 || vol > 100) {
+ vol = 50;
+ }
+ document.getElementById("volume").value = vol;
+ setVolume(vol);
+
+ let skin = getLocalPref("skin", "f91w");
+ if (!validSkins.includes(skin)) {
+ skin = "f91w";
+ }
+ document.getElementById(skin).checked = true;
+ setSkin(skin);
}
- toggleSkin();
+ loadPrefs();
</script>
{{{ SCRIPT }}}
diff --git a/watch-library/simulator/watch/watch_buzzer.c b/watch-library/simulator/watch/watch_buzzer.c
index 68d9a139..211235df 100644
--- a/watch-library/simulator/watch/watch_buzzer.c
+++ b/watch-library/simulator/watch/watch_buzzer.c
@@ -152,7 +152,7 @@ void watch_set_buzzer_on(void) {
}
audioContext._oscillator.frequency.value = 1e6/$0;
- audioContext._gain.gain.value = 1;
+ audioContext._gain.gain.value = volumeGain;
}, buzzer_period);
}
diff --git a/watch-library/simulator/watch/watch_rtc.c b/watch-library/simulator/watch/watch_rtc.c
index fa80d6b4..f6279eed 100644
--- a/watch-library/simulator/watch/watch_rtc.c
+++ b/watch-library/simulator/watch/watch_rtc.c
@@ -97,8 +97,7 @@ void watch_rtc_register_periodic_callback(ext_irq_cb_t callback, uint8_t frequen
// 0x01 (1 Hz) will have 7 leading zeros for PER7. 0xF0 (128 Hz) will have no leading zeroes for PER0.
uint8_t per_n = __builtin_clz(tmp);
- // this also maps nicely to an index for our list of tick callbacks.
- double interval = 1000 / frequency; // in msec
+ double interval = 1000.0 / frequency; // in msec
if (tick_callbacks[per_n] != -1) emscripten_clear_interval(tick_callbacks[per_n]);
tick_callbacks[per_n] = emscripten_set_interval(watch_invoke_periodic_callback, interval, (void *)callback);
@@ -115,7 +114,7 @@ void watch_rtc_disable_periodic_callback(uint8_t frequency) {
void watch_rtc_disable_matching_periodic_callbacks(uint8_t mask) {
for (int i = 0; i < 8; i++) {
- if (tick_callbacks[i] != -1 && (mask & (1 << (7 - i))) != 0) {
+ if (tick_callbacks[i] != -1 && (mask & (1 << i)) != 0) {
emscripten_clear_interval(tick_callbacks[i]);
tick_callbacks[i] = -1;
}