summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.github/workflows/main.yml11
-rw-r--r--.gitignore1
-rwxr-xr-xapps/accelerometer-test/Makefile (renamed from apps/accelerometer-test/make/Makefile)6
-rwxr-xr-xapps/starter-project/Makefile (renamed from apps/starter-project/make/Makefile)22
4 files changed, 22 insertions, 18 deletions
diff --git a/.github/workflows/main.yml b/.github/workflows/main.yml
index f07c5db0..7112d820 100644
--- a/.github/workflows/main.yml
+++ b/.github/workflows/main.yml
@@ -10,11 +10,14 @@ jobs:
steps:
- name: Checkout
uses: actions/checkout@v2
- - name: Compile beats-time app
+ - name: Compile starter-project app
run: make
- working-directory: 'apps/beats-time/make'
+ working-directory: 'apps/starter-project'
+ - name: Compile accelerometer-test app
+ run: make
+ working-directory: 'apps/accelerometer-test'
- name: Upload UF2
uses: actions/upload-artifact@v2
with:
- name: watch.uf2
- path: apps/beats-time/make/build/watch.uf2
+ name: watch.uf2.uf2
+ path: apps/**/build/watch.uf2
diff --git a/.gitignore b/.gitignore
index 6c5ca630..1100e911 100644
--- a/.gitignore
+++ b/.gitignore
@@ -13,6 +13,7 @@
*.uf2
*srec
.DS_Store
+.idea/
.vs
.vscode
docs/ \ No newline at end of file
diff --git a/apps/accelerometer-test/make/Makefile b/apps/accelerometer-test/Makefile
index c66ad20c..5534c178 100755
--- a/apps/accelerometer-test/make/Makefile
+++ b/apps/accelerometer-test/Makefile
@@ -1,10 +1,10 @@
-TOP = ../../..
+TOP = ../..
include $(TOP)/make.mk
INCLUDES += \
- -I../
+ -I./
SRCS += \
- ../app.c
+ ./app.c
include $(TOP)/rules.mk
diff --git a/apps/starter-project/make/Makefile b/apps/starter-project/Makefile
index 09a59a05..7cb3c48d 100755
--- a/apps/starter-project/make/Makefile
+++ b/apps/starter-project/Makefile
@@ -1,26 +1,26 @@
# Leave these lines at the top of the file.
# TOP should get us to the root of the project...
-TOP = ../../..
+TOP = ../..
# ...and make.mk has all the watch library sources and includes.
include $(TOP)/make.mk
-# If you add any other subdirectories with header files you wish to include, add them after ../
+# If you add any other subdirectories with header files you wish to include, add them after ./
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# INCLUDES += \
-# -I../ \
-# -I../drivers/ \
-# -I../utils/
+# -I./ \
+# -I drivers/ \
+# -I utils/
INCLUDES += \
- -I../ \
+ -I./ \
-# If you add any other source files you wish to compile, add them after ../app.c
+# If you add any other source files you wish to compile, add them after app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# SRCS += \
-# ../app.c \
-# ../drivers/bmp280.c \
-# ../utils/temperature.c
+# ./app.c \
+# ./drivers/bmp280.c \
+# ./utils/temperature.c
SRCS += \
- ../app.c \
+ ./app.c \
# Leave this line at the bottom of the file; rules.mk has all the targets for making your project.
include $(TOP)/rules.mk