summaryrefslogtreecommitdiffstats
path: root/apps/Sensor Watch Starter Project/make/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'apps/Sensor Watch Starter Project/make/Makefile')
-rwxr-xr-xapps/Sensor Watch Starter Project/make/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/apps/Sensor Watch Starter Project/make/Makefile b/apps/Sensor Watch Starter Project/make/Makefile
new file mode 100755
index 00000000..09a59a05
--- /dev/null
+++ b/apps/Sensor Watch Starter Project/make/Makefile
@@ -0,0 +1,26 @@
+# Leave these lines at the top of the file.
+# TOP should get us to the root of the project...
+TOP = ../../..
+# ...and make.mk has all the watch library sources and includes.
+include $(TOP)/make.mk
+
+# If you add any other subdirectories with header files you wish to include, add them after ../
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# INCLUDES += \
+# -I../ \
+# -I../drivers/ \
+# -I../utils/
+INCLUDES += \
+ -I../ \
+
+# If you add any other source files you wish to compile, add them after ../app.c
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# SRCS += \
+# ../app.c \
+# ../drivers/bmp280.c \
+# ../utils/temperature.c
+SRCS += \
+ ../app.c \
+
+# Leave this line at the bottom of the file; rules.mk has all the targets for making your project.
+include $(TOP)/rules.mk