summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/make.mk b/make.mk
index 955ea310..bb2d1537 100644
--- a/make.mk
+++ b/make.mk
@@ -121,6 +121,7 @@ SRCS += \
$(TOP)/watch-library/hardware/watch/watch_storage.c \
$(TOP)/watch-library/hardware/watch/watch_deepsleep.c \
$(TOP)/watch-library/hardware/watch/watch_private.c \
+ $(TOP)/watch-library/hardware/watch/watch_private_cdc.c \
$(TOP)/watch-library/hardware/watch/watch.c \
$(TOP)/watch-library/hardware/hal/src/hal_atomic.c \
$(TOP)/watch-library/hardware/hal/src/hal_delay.c \
@@ -229,3 +230,9 @@ endif
ifeq ($(BOARD), OSO-FEAL-A1-00)
CFLAGS += -DCRYSTALLESS
endif
+
+# Build options to customize movement and faces
+
+ifdef CLOCK_FACE_24H_ONLY
+CFLAGS += -DCLOCK_FACE_24H_ONLY
+endif