summaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 1aa135a8..2f2f3922 100644
--- a/rules.mk
+++ b/rules.mk
@@ -4,6 +4,8 @@ OBJS = $(addprefix $(BUILD)/, $(notdir %/$(subst .c,.o, $(SRCS))))
SUBMODULES = tinyusb
+COBRA = cobra -f
+
ifndef EMSCRIPTEN
all: directory $(SUBMODULES) $(BUILD)/$(BIN).elf $(BUILD)/$(BIN).hex $(BUILD)/$(BIN).bin $(BUILD)/$(BIN).uf2 size
else
@@ -54,4 +56,7 @@ clean:
@echo clean
@-rm -rf $(BUILD)
+analyze:
+ @$(COBRA) basic $(INCLUDES) $(DEFINES) $(SRCS)
+
-include $(wildcard $(BUILD)/*.d)