summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/board_test/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/device/board_test/Makefile')
-rwxr-xr-xtinyusb/examples/device/board_test/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/tinyusb/examples/device/board_test/Makefile b/tinyusb/examples/device/board_test/Makefile
new file mode 100755
index 00000000..b65575ce
--- /dev/null
+++ b/tinyusb/examples/device/board_test/Makefile
@@ -0,0 +1,18 @@
+include ../../../tools/top.mk
+include ../../make.mk
+
+INC += \
+ src \
+ $(TOP)/hw \
+
+# Example source
+EXAMPLE_SOURCE += $(wildcard src/*.c)
+SRC_C += $(addprefix $(CURRENT_PATH)/, $(EXAMPLE_SOURCE))
+
+# board_test example is special example that doesn't enable device or host stack
+# This can cause some TinyUSB API missing, this hack to allow us to fill those API
+# to pass the compilation process
+CFLAGS += \
+ -D"tud_int_handler(x)= " \
+
+include ../../rules.mk