summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/hid_composite_freertos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/device/hid_composite_freertos/CMakeLists.txt')
-rwxr-xr-xtinyusb/examples/device/hid_composite_freertos/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/tinyusb/examples/device/hid_composite_freertos/CMakeLists.txt b/tinyusb/examples/device/hid_composite_freertos/CMakeLists.txt
new file mode 100755
index 00000000..ed734b95
--- /dev/null
+++ b/tinyusb/examples/device/hid_composite_freertos/CMakeLists.txt
@@ -0,0 +1,17 @@
+cmake_minimum_required(VERSION 3.5)
+
+# use BOARD-Directory name for project id
+get_filename_component(PROJECT ${CMAKE_CURRENT_SOURCE_DIR} NAME)
+set(PROJECT ${BOARD}-${PROJECT})
+
+# TOP is absolute path to root directory of TinyUSB git repo
+set(TOP "../../..")
+get_filename_component(TOP "${TOP}" REALPATH)
+
+# Check for -DFAMILY=
+if(FAMILY MATCHES "^esp32s[2-3]")
+ include(${TOP}/hw/bsp/${FAMILY}/family.cmake)
+ project(${PROJECT})
+else()
+ message(FATAL_ERROR "Invalid FAMILY specified: ${FAMILY}")
+endif()