summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/device/net_lwip_webserver/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/device/net_lwip_webserver/Makefile')
m---------tinyusb0
-rwxr-xr-xtinyusb/examples/device/net_lwip_webserver/Makefile61
2 files changed, 0 insertions, 61 deletions
diff --git a/tinyusb b/tinyusb
new file mode 160000
+Subproject f8288be03f28ad7b944e6925f49422dfa39202c
diff --git a/tinyusb/examples/device/net_lwip_webserver/Makefile b/tinyusb/examples/device/net_lwip_webserver/Makefile
deleted file mode 100755
index c3e0d889..00000000
--- a/tinyusb/examples/device/net_lwip_webserver/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-DEPS_SUBMODULES += lib/lwip
-
-include ../../../tools/top.mk
-include ../../make.mk
-
-CFLAGS += \
- -DPBUF_POOL_SIZE=2 \
- -DTCP_WND=2*TCP_MSS \
- -DHTTPD_USE_CUSTOM_FSDATA=0
-
-INC += \
- src \
- $(TOP)/hw \
- $(TOP)/lib/lwip/src/include \
- $(TOP)/lib/lwip/src/include/ipv4 \
- $(TOP)/lib/lwip/src/include/lwip/apps \
- $(TOP)/lib/networking
-
-# Example source
-EXAMPLE_SOURCE += $(wildcard src/*.c)
-SRC_C += $(addprefix $(CURRENT_PATH)/, $(EXAMPLE_SOURCE))
-
-# lwip sources
-SRC_C += \
- lib/lwip/src/core/altcp.c \
- lib/lwip/src/core/altcp_alloc.c \
- lib/lwip/src/core/altcp_tcp.c \
- lib/lwip/src/core/def.c \
- lib/lwip/src/core/dns.c \
- lib/lwip/src/core/inet_chksum.c \
- lib/lwip/src/core/init.c \
- lib/lwip/src/core/ip.c \
- lib/lwip/src/core/mem.c \
- lib/lwip/src/core/memp.c \
- lib/lwip/src/core/netif.c \
- lib/lwip/src/core/pbuf.c \
- lib/lwip/src/core/raw.c \
- lib/lwip/src/core/stats.c \
- lib/lwip/src/core/sys.c \
- lib/lwip/src/core/tcp.c \
- lib/lwip/src/core/tcp_in.c \
- lib/lwip/src/core/tcp_out.c \
- lib/lwip/src/core/timeouts.c \
- lib/lwip/src/core/udp.c \
- lib/lwip/src/core/ipv4/autoip.c \
- lib/lwip/src/core/ipv4/dhcp.c \
- lib/lwip/src/core/ipv4/etharp.c \
- lib/lwip/src/core/ipv4/icmp.c \
- lib/lwip/src/core/ipv4/igmp.c \
- lib/lwip/src/core/ipv4/ip4.c \
- lib/lwip/src/core/ipv4/ip4_addr.c \
- lib/lwip/src/core/ipv4/ip4_frag.c \
- lib/lwip/src/netif/ethernet.c \
- lib/lwip/src/netif/slipif.c \
- lib/lwip/src/apps/http/httpd.c \
- lib/lwip/src/apps/http/fs.c \
- lib/networking/dhserver.c \
- lib/networking/dnserver.c \
- lib/networking/rndis_reports.c
-
-include ../../rules.mk