summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/host/cdc_msc_hid/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/host/cdc_msc_hid/CMakeLists.txt')
-rwxr-xr-xtinyusb/examples/host/cdc_msc_hid/CMakeLists.txt29
1 files changed, 0 insertions, 29 deletions
diff --git a/tinyusb/examples/host/cdc_msc_hid/CMakeLists.txt b/tinyusb/examples/host/cdc_msc_hid/CMakeLists.txt
deleted file mode 100755
index 0a99bc3a..00000000
--- a/tinyusb/examples/host/cdc_msc_hid/CMakeLists.txt
+++ /dev/null
@@ -1,29 +0,0 @@
-cmake_minimum_required(VERSION 3.5)
-
-include(${CMAKE_CURRENT_SOURCE_DIR}/../../../hw/bsp/family_support.cmake)
-
-# gets PROJECT name for the example (e.g. <BOARD>-<DIR_NAME>)
-family_get_project_name(PROJECT ${CMAKE_CURRENT_LIST_DIR})
-
-project(${PROJECT})
-
-# Checks this example is valid for the family and initializes the project
-family_initialize_project(${PROJECT} ${CMAKE_CURRENT_LIST_DIR})
-
-add_executable(${PROJECT})
-
-# Example source
-target_sources(${PROJECT} PUBLIC
- ${CMAKE_CURRENT_SOURCE_DIR}/src/hid_app.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/main.c
- ${CMAKE_CURRENT_SOURCE_DIR}/src/msc_app.c
- )
-
-# Example include
-target_include_directories(${PROJECT} PUBLIC
- ${CMAKE_CURRENT_SOURCE_DIR}/src
- )
-
-# Configure compilation flags and libraries for the example... see the corresponding function
-# in hw/bsp/FAMILY/family.cmake for details.
-family_configure_host_example(${PROJECT}) \ No newline at end of file