summaryrefslogtreecommitdiffstats
path: root/tinyusb/examples/host/hid_controller/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/examples/host/hid_controller/Makefile')
m---------tinyusb0
-rwxr-xr-xtinyusb/examples/host/hid_controller/Makefile30
2 files changed, 0 insertions, 30 deletions
diff --git a/tinyusb b/tinyusb
new file mode 160000
+Subproject f8288be03f28ad7b944e6925f49422dfa39202c
diff --git a/tinyusb/examples/host/hid_controller/Makefile b/tinyusb/examples/host/hid_controller/Makefile
deleted file mode 100755
index 6f59faee..00000000
--- a/tinyusb/examples/host/hid_controller/Makefile
+++ /dev/null
@@ -1,30 +0,0 @@
-include ../../../tools/top.mk
-include ../../make.mk
-
-INC += \
- src \
- $(TOP)/hw \
-
-# Example source
-EXAMPLE_SOURCE += \
- src/hid_app.c \
- src/main.c
-
-SRC_C += $(addprefix $(CURRENT_PATH)/, $(EXAMPLE_SOURCE))
-
-CFLAGS += -Wno-error=cast-align
-
-# TinyUSB Host Stack source
-SRC_C += \
- src/class/cdc/cdc_host.c \
- src/class/hid/hid_host.c \
- src/class/msc/msc_host.c \
- src/host/hub.c \
- src/host/usbh.c \
- src/host/usbh_control.c \
- src/portable/ehci/ehci.c \
- src/portable/ohci/ohci.c \
- src/portable/nxp/transdimension/hcd_transdimension.c \
- src/portable/nxp/lpc17_40/hcd_lpc17_40.c
-
-include ../../rules.mk