summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt')
-rwxr-xr-xtinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt b/tinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt
new file mode 100755
index 00000000..6d0fcbc8
--- /dev/null
+++ b/tinyusb/hw/bsp/esp32s3/components/led_strip/CMakeLists.txt
@@ -0,0 +1,8 @@
+set(component_srcs "src/led_strip_rmt_ws2812.c")
+
+idf_component_register(SRCS "${component_srcs}"
+ INCLUDE_DIRS "include"
+ PRIV_INCLUDE_DIRS ""
+ PRIV_REQUIRES "driver"
+ REQUIRES "")
+