summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/lpc54/boards
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/lpc54/boards')
-rwxr-xr-xtinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.h59
-rwxr-xr-xtinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.mk13
-rwxr-xr-xtinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.h59
-rwxr-xr-xtinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.mk18
4 files changed, 0 insertions, 149 deletions
diff --git a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.h b/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.h
deleted file mode 100755
index b1ad4258..00000000
--- a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.h
+++ /dev/null
@@ -1,59 +0,0 @@
-/*
- * The MIT License (MIT)
- *
- * Copyright (c) 2021, Ha Thach (tinyusb.org)
- *
- * Permission is hereby granted, free of charge, to any person obtaining a copy
- * of this software and associated documentation files (the "Software"), to deal
- * in the Software without restriction, including without limitation the rights
- * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
- * copies of the Software, and to permit persons to whom the Software is
- * furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice shall be included in
- * all copies or substantial portions of the Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
- * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
- * THE SOFTWARE.
- *
- * This file is part of the TinyUSB stack.
- */
-
-#ifndef BOARD_H_
-#define BOARD_H_
-
-#ifdef __cplusplus
- extern "C" {
-#endif
-
-// LED
-#define LED_PORT 0
-#define LED_PIN 29
-#define LED_STATE_ON 0
-
-// WAKE button
-#define BUTTON_PORT 0
-#define BUTTON_PIN 24
-#define BUTTON_STATE_ACTIVE 0
-
-// UART
-#define UART_DEV USART0
-#define UART_RX_PINMUX 0, 0, IOCON_PIO_DIG_FUNC1_EN
-#define UART_TX_PINMUX 0, 1, IOCON_PIO_DIG_FUNC1_EN
-
-// USB0 VBUS
-#define USB0_VBUS_PINMUX 1, 6, IOCON_PIO_DIG_FUNC7_EN
-
-// XTAL
-//#define XTAL0_CLK_HZ (16 * 1000 * 1000U)
-
-#ifdef __cplusplus
- }
-#endif
-
-#endif
diff --git a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.mk b/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.mk
deleted file mode 100755
index 6e33d8cb..00000000
--- a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54114/board.mk
+++ /dev/null
@@ -1,13 +0,0 @@
-MCU_VARIANT = LPC54114
-MCU_CORE = LPC54114_cm4
-
-CFLAGS += -DCPU_LPC54114J256BD64_cm4
-LD_FILE = $(MCU_DIR)/gcc/LPC54114J256_cm4_flash.ld
-
-LIBS += $(TOP)/$(MCU_DIR)/gcc/libpower_cm4_hardabi.a
-
-JLINK_DEVICE = LPC54114J256_M4
-PYOCD_TARGET = LPC54114
-
-# flash using pyocd
-flash: flash-pyocd
diff --git a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.h b/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.h
deleted file mode 100755
index 67027751..00000000
--- a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.h
+++ /dev/null
@@ -1,59 +0,0 @@
-/*
- * The MIT License (MIT)
- *
- * Copyright (c) 2021, Ha Thach (tinyusb.org)
- *
- * Permission is hereby granted, free of charge, to any person obtaining a copy
- * of this software and associated documentation files (the "Software"), to deal
- * in the Software without restriction, including without limitation the rights
- * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
- * copies of the Software, and to permit persons to whom the Software is
- * furnished to do so, subject to the following conditions:
- *
- * The above copyright notice and this permission notice shall be included in
- * all copies or substantial portions of the Software.
- *
- * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
- * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
- * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
- * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
- * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
- * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
- * THE SOFTWARE.
- *
- * This file is part of the TinyUSB stack.
- */
-
-#ifndef BOARD_H_
-#define BOARD_H_
-
-#ifdef __cplusplus
- extern "C" {
-#endif
-
-// LED
-#define LED_PORT 2
-#define LED_PIN 2
-#define LED_STATE_ON 0
-
-// WAKE button
-#define BUTTON_PORT 1
-#define BUTTON_PIN 1
-#define BUTTON_STATE_ACTIVE 0
-
-// UART
-#define UART_DEV USART0
-#define UART_RX_PINMUX 0, 29, IOCON_PIO_DIG_FUNC1_EN
-#define UART_TX_PINMUX 0, 30, IOCON_PIO_DIG_FUNC1_EN
-
-// USB0 VBUS
-#define USB0_VBUS_PINMUX 0, 22, IOCON_PIO_DIG_FUNC7_EN
-
-// XTAL
-//#define XTAL0_CLK_HZ (16 * 1000 * 1000U)
-
-#ifdef __cplusplus
- }
-#endif
-
-#endif
diff --git a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.mk b/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.mk
deleted file mode 100755
index 925374cc..00000000
--- a/tinyusb/hw/bsp/lpc54/boards/lpcxpresso54628/board.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-MCU_VARIANT = LPC54628
-MCU_CORE = LPC54628
-
-PORT ?= 0
-
-CFLAGS += -DCPU_LPC54628J512ET180
-CFLAGS += -Wno-error=double-promotion
-
-LD_FILE = $(MCU_DIR)/gcc/LPC54628J512_flash.ld
-
-LIBS += $(TOP)/$(MCU_DIR)/gcc/libpower_hardabi.a
-
-JLINK_DEVICE = LPC54628J512
-PYOCD_TARGET = LPC54628
-
-#flash: flash-pyocd
-
-flash: flash-jlink \ No newline at end of file