summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/nrf/boards/pca10059/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/nrf/boards/pca10059/board.mk')
m---------tinyusb0
-rwxr-xr-xtinyusb/hw/bsp/nrf/boards/pca10059/board.mk15
2 files changed, 0 insertions, 15 deletions
diff --git a/tinyusb b/tinyusb
new file mode 160000
+Subproject f8288be03f28ad7b944e6925f49422dfa39202c
diff --git a/tinyusb/hw/bsp/nrf/boards/pca10059/board.mk b/tinyusb/hw/bsp/nrf/boards/pca10059/board.mk
deleted file mode 100755
index 0b82ecdb..00000000
--- a/tinyusb/hw/bsp/nrf/boards/pca10059/board.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-MCU_VARIANT = nrf52840
-CFLAGS += -DNRF52840_XXAA
-
-LD_FILE = $(BOARD_PATH)/$(BOARD).ld
-
-# flash using Nordic nrfutil (pip2 install nrfutil)
-# make BOARD=pca10059 SERIAL=/dev/ttyACM0 all flash
-NRFUTIL = nrfutil
-
-$(BUILD)/$(PROJECT).zip: $(BUILD)/$(PROJECT).hex
- $(NRFUTIL) pkg generate --hw-version 52 --sd-req 0x0000 --debug-mode --application $^ $@
-
-flash: $(BUILD)/$(PROJECT).zip
- @:$(call check_defined, SERIAL, example: SERIAL=/dev/ttyACM0)
- $(NRFUTIL) dfu usb-serial --package $^ -p $(SERIAL) -b 115200