summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/rx/boards/gr_citrus/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/rx/boards/gr_citrus/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/rx/boards/gr_citrus/board.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/rx/boards/gr_citrus/board.mk b/tinyusb/hw/bsp/rx/boards/gr_citrus/board.mk
new file mode 100755
index 00000000..0eba9461
--- /dev/null
+++ b/tinyusb/hw/bsp/rx/boards/gr_citrus/board.mk
@@ -0,0 +1,24 @@
+DEPS_SUBMODULES += hw/mcu/renesas/rx
+
+CFLAGS += \
+ -mcpu=rx610 \
+ -misa=v1 \
+ -DCFG_TUSB_MCU=OPT_MCU_RX63X
+
+MCU_DIR = hw/mcu/renesas/rx/rx63n
+
+# All source paths should be relative to the top level.
+LD_FILE = $(BOARD_PATH)/r5f5631fd.ld
+
+# For freeRTOS port source
+FREERTOS_PORT = RX600
+
+# For flash-jlink target
+JLINK_DEVICE = R5F5631F
+JLINK_IF = JTAG
+
+# For flash-pyocd target
+PYOCD_TARGET =
+
+# flash using jlink
+flash: flash-jlink