summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk b/tinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk
new file mode 100755
index 00000000..e351cf0b
--- /dev/null
+++ b/tinyusb/hw/bsp/samd11/boards/samd11_xplained/board.mk
@@ -0,0 +1,11 @@
+CFLAGS += -D__SAMD11D14AM__
+
+# All source paths should be relative to the top level.
+LD_FILE = $(BOARD_PATH)/samd11d14am_flash.ld
+
+# For flash-jlink target
+JLINK_DEVICE = ATSAMD11D14
+
+# flash using edbg
+flash: $(BUILD)/$(PROJECT).bin
+ edbg -b -t samd11 -e -pv -f $<