summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk b/tinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk
new file mode 100755
index 00000000..5cd82735
--- /dev/null
+++ b/tinyusb/hw/bsp/samd21/boards/atsamd21_xpro/board.mk
@@ -0,0 +1,10 @@
+CFLAGS += -D__SAMD21J18A__
+
+# All source paths should be relative to the top level.
+LD_FILE = $(BOARD_PATH)/samd21j18a_flash.ld
+
+# For flash-jlink target
+JLINK_DEVICE = ATSAMD21J18
+
+# flash using jlink
+flash: flash-jlink