summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk b/tinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk
new file mode 100755
index 00000000..81b4ecdc
--- /dev/null
+++ b/tinyusb/hw/bsp/saml2x/boards/atsaml21_xpro/board.mk
@@ -0,0 +1,12 @@
+CFLAGS += -D__SAML21J18B__
+
+SAML_VARIANT = saml21
+
+# All source paths should be relative to the top level.
+LD_FILE = $(BOARD_PATH)/saml21j18b_flash.ld
+
+# For flash-jlink target
+JLINK_DEVICE = ATSAML21J18
+
+# flash using jlink
+flash: flash-jlink