summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk b/tinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk
new file mode 100755
index 00000000..9e636cd7
--- /dev/null
+++ b/tinyusb/hw/bsp/stm32f0/boards/stm32f070rbnucleo/board.mk
@@ -0,0 +1,11 @@
+CFLAGS += -DSTM32F070xB
+
+LD_FILE = $(BOARD_PATH)/stm32F070rbtx_flash.ld
+
+SRC_S += $(ST_CMSIS)/Source/Templates/gcc/startup_stm32f070xb.s
+
+# For flash-jlink target
+JLINK_DEVICE = stm32f070rb
+
+# flash target using on-board stlink
+flash: flash-stlink