summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk b/tinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk
new file mode 100755
index 00000000..2ef0ee63
--- /dev/null
+++ b/tinyusb/hw/bsp/stm32f0/boards/stm32f072disco/board.mk
@@ -0,0 +1,11 @@
+CFLAGS += -DSTM32F072xB
+
+LD_FILE = $(BOARD_PATH)/STM32F072RBTx_FLASH.ld
+
+SRC_S += $(ST_CMSIS)/Source/Templates/gcc/startup_stm32f072xb.s
+
+# For flash-jlink target
+JLINK_DEVICE = stm32f072rb
+
+# flash target using on-board stlink
+flash: flash-stlink