summaryrefslogtreecommitdiffstats
path: root/tinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk
diff options
context:
space:
mode:
Diffstat (limited to 'tinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk')
-rwxr-xr-xtinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/tinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk b/tinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk
new file mode 100755
index 00000000..2400a4ba
--- /dev/null
+++ b/tinyusb/hw/bsp/stm32f7/boards/stm32f767nucleo/board.mk
@@ -0,0 +1,12 @@
+PORT ?= 0
+SPEED ?= full
+
+CFLAGS += \
+ -DSTM32F767xx \
+ -DHSE_VALUE=8000000 \
+
+LD_FILE = $(BOARD_PATH)/STM32F767ZITx_FLASH.ld
+SRC_S += $(ST_CMSIS)/Source/Templates/gcc/startup_stm32f767xx.s
+
+# flash target using on-board stlink
+flash: flash-stlink