aboutsummaryrefslogtreecommitdiffstats
path: root/config
diff options
context:
space:
mode:
authorRoger Pau Monne <roger.pau@citrix.com>2012-10-26 17:02:22 +0100
committerRoger Pau Monne <roger.pau@citrix.com>2012-10-26 17:02:22 +0100
commit706549a9de6946e04b2a48f1954a636dbc70b152 (patch)
tree3d58d22dac20ab5dc9dfed9da6cf71ac7d235ee3 /config
parentd619b628a2adc709d59bffef9b8792f3310c4bd9 (diff)
downloadxen-706549a9de6946e04b2a48f1954a636dbc70b152.tar.gz
xen-706549a9de6946e04b2a48f1954a636dbc70b152.tar.bz2
xen-706549a9de6946e04b2a48f1954a636dbc70b152.zip
libfsimage: add ext4 support for CentOS 5.x
CentOS 5.x forked e2fs ext4 support into a different package called e4fs, and so headers and library names changed from ext2fs to ext4fs. Check if ext4fs/ext2fs.h and -lext4fs work, and use that instead of ext2fs to build libfsimage. This patch assumes that if the ext4fs library is present it should always be used instead of ext2fs. This patch includes a rework of the ext2fs check, a new ext4fs check and a minor modification in libfsimage to use the correct library. Signed-off-by: Roger Pau Monne <roger.pau@citrix.com> Acked-by: Ian Campbell <ian.campbell@citrix.com> Committed-by: Ian Campbell <ian.campbell@citrix.com> xen-unstable changeset: 25895:98e1ba6a672a Backport-requested-by: Ian Campbell <Ian.Campbell@citrix.com> Committed-by: Ian Jackson <ian.jackson@eu.citrix.com>
Diffstat (limited to 'config')
-rw-r--r--config/Tools.mk.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/config/Tools.mk.in b/config/Tools.mk.in
index 21ad0ef270..a6ecf48dfd 100644
--- a/config/Tools.mk.in
+++ b/config/Tools.mk.in
@@ -57,5 +57,5 @@ CONFIG_SYSTEM_LIBAIO:= @system_aio@
ZLIB := @zlib@
CONFIG_LIBICONV := @libiconv@
CONFIG_GCRYPT := @libgcrypt@
-CONFIG_EXT2FS := @libext2fs@
+EXTFS_LIBS := @EXTFS_LIBS@
CURSES_LIBS := @CURSES_LIBS@