summaryrefslogtreecommitdiffstats
path: root/firmware/configuration/t167_default/Makefile.inc
diff options
context:
space:
mode:
authorcpldcpu <cpldcpu@gmail.com>2014-03-16 17:56:59 +0100
committercpldcpu <cpldcpu@gmail.com>2014-03-16 17:56:59 +0100
commit71342b4efaa6a7907190d1378dae63cb8dbd601a (patch)
tree9d1eeda0c0260ab3b2bd8376574791dbc25141e1 /firmware/configuration/t167_default/Makefile.inc
parent41f1f2560dca9a7cac581fcc3f88cd246dc592cd (diff)
downloadmicronucleus-71342b4efaa6a7907190d1378dae63cb8dbd601a.tar.gz
micronucleus-71342b4efaa6a7907190d1378dae63cb8dbd601a.tar.bz2
micronucleus-71342b4efaa6a7907190d1378dae63cb8dbd601a.zip
firmware: attiny 167 config
Diffstat (limited to 'firmware/configuration/t167_default/Makefile.inc')
-rw-r--r--firmware/configuration/t167_default/Makefile.inc21
1 files changed, 21 insertions, 0 deletions
diff --git a/firmware/configuration/t167_default/Makefile.inc b/firmware/configuration/t167_default/Makefile.inc
new file mode 100644
index 0000000..ca17884
--- /dev/null
+++ b/firmware/configuration/t167_default/Makefile.inc
@@ -0,0 +1,21 @@
+# Name: Makefile
+# Project: Micronucleus
+# License: GNU GPL v2 (see License.txt)
+#
+# Controller type: ATtiny 167
+# Configuration: Default configuration.
+# Last Change: Mar 16,2014
+
+
+F_CPU = 16000000
+DEVICE = attiny167
+
+# hexadecimal address for bootloader section to begin. To calculate the best value:
+# - make clean; make main.hex; ### output will list data: 2124 (or something like that)
+# - for the size of your device (8kb = 1024 * 8 = 8192) subtract above value 2124... = 6068
+# - How many pages in is that? 6068 / 64 (tiny85 page size in bytes) = 94.8125
+# - round that down to 94 - our new bootloader address is 94 * 64 = 6016, in hex = 1780
+BOOTLOADER_ADDRESS = 3980
+
+FUSEOPT = # TODO
+FUSEOPT_DISABLERESET = # TODO