aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-09-07 22:26:44 +0300
committerbarthess <barthess@yandex.ru>2015-09-07 22:26:44 +0300
commit51514b134ee5bfca3647647620920747b41eaf3a (patch)
tree045b1ddc975d11adbe3f82367d3f0cfc2f563011
parent40014ce2c584274e5e1cee7d08f858bbfc0407f8 (diff)
downloadChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.tar.gz
ChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.tar.bz2
ChibiOS-Contrib-51514b134ee5bfca3647647620920747b41eaf3a.zip
STM32 testhal. Fixed paths in makefiles
-rw-r--r--testhal/STM32/STM32F0xx/onewire/.project2
-rw-r--r--testhal/STM32/STM32F0xx/onewire/Makefile1
-rw-r--r--testhal/STM32/STM32F0xx/onewire/halconf_community.h7
-rw-r--r--testhal/STM32/STM32F1xx/onewire/.project2
-rw-r--r--testhal/STM32/STM32F4xx/EICU/Makefile1
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_NAND/.project2
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_NAND/Makefile1
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_NAND/halconf_community.h7
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SDRAM/.project2
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SDRAM/Makefile1
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/.project2
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile1
-rw-r--r--testhal/STM32/STM32F4xx/FSMC_SRAM/halconf_community.h7
-rw-r--r--testhal/STM32/STM32F4xx/onewire/.project2
-rw-r--r--testhal/STM32/STM32F4xx/onewire/Makefile1
15 files changed, 27 insertions, 12 deletions
diff --git a/testhal/STM32/STM32F0xx/onewire/.project b/testhal/STM32/STM32F0xx/onewire/.project
index 856b65d..be76784 100644
--- a/testhal/STM32/STM32F0xx/onewire/.project
+++ b/testhal/STM32/STM32F0xx/onewire/.project
@@ -84,7 +84,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F0xx/onewire/Makefile b/testhal/STM32/STM32F0xx/onewire/Makefile
index a70bafa..a26473e 100644
--- a/testhal/STM32/STM32F0xx/onewire/Makefile
+++ b/testhal/STM32/STM32F0xx/onewire/Makefile
@@ -76,7 +76,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
diff --git a/testhal/STM32/STM32F0xx/onewire/halconf_community.h b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
index e90257b..6c628c0 100644
--- a/testhal/STM32/STM32F0xx/onewire/halconf_community.h
+++ b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
@@ -45,6 +45,13 @@
#define HAL_USE_EICU FALSE
#endif
+/**
+ * @brief Enables the community subsystem.
+ */
+#if !defined(HAL_USE_CRC) || defined(__DOXYGEN__)
+#define HAL_USE_CRC FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/
diff --git a/testhal/STM32/STM32F1xx/onewire/.project b/testhal/STM32/STM32F1xx/onewire/.project
index 8f7973b..a2c0d64 100644
--- a/testhal/STM32/STM32F1xx/onewire/.project
+++ b/testhal/STM32/STM32F1xx/onewire/.project
@@ -84,7 +84,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F4xx/EICU/Makefile b/testhal/STM32/STM32F4xx/EICU/Makefile
index 7712af3..c6bdbaf 100644
--- a/testhal/STM32/STM32F4xx/EICU/Makefile
+++ b/testhal/STM32/STM32F4xx/EICU/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
diff --git a/testhal/STM32/STM32F4xx/FSMC_NAND/.project b/testhal/STM32/STM32F4xx/FSMC_NAND/.project
index c141077..63225d6 100644
--- a/testhal/STM32/STM32F4xx/FSMC_NAND/.project
+++ b/testhal/STM32/STM32F4xx/FSMC_NAND/.project
@@ -32,7 +32,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile b/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
index 485cb7e..cc0dcff 100644
--- a/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_NAND/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
diff --git a/testhal/STM32/STM32F4xx/FSMC_NAND/halconf_community.h b/testhal/STM32/STM32F4xx/FSMC_NAND/halconf_community.h
index 5c979fa..bc09065 100644
--- a/testhal/STM32/STM32F4xx/FSMC_NAND/halconf_community.h
+++ b/testhal/STM32/STM32F4xx/FSMC_NAND/halconf_community.h
@@ -45,6 +45,13 @@
#define HAL_USE_EICU FALSE
#endif
+/**
+ * @brief Enables the CRC subsystem.
+ */
+#if !defined(HAL_USE_CRC) || defined(__DOXYGEN__)
+#define HAL_USE_CRC FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/
diff --git a/testhal/STM32/STM32F4xx/FSMC_SDRAM/.project b/testhal/STM32/STM32F4xx/FSMC_SDRAM/.project
index e0391df..f6fd941 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SDRAM/.project
+++ b/testhal/STM32/STM32F4xx/FSMC_SDRAM/.project
@@ -32,7 +32,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F4xx/FSMC_SDRAM/Makefile b/testhal/STM32/STM32F4xx/FSMC_SDRAM/Makefile
index fc2f5c2..b75bd18 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SDRAM/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_SDRAM/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/.project b/testhal/STM32/STM32F4xx/FSMC_SRAM/.project
index b25c098..dd8ba3a 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/.project
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/.project
@@ -32,7 +32,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
index 3a70aad..1f2c059 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
diff --git a/testhal/STM32/STM32F4xx/FSMC_SRAM/halconf_community.h b/testhal/STM32/STM32F4xx/FSMC_SRAM/halconf_community.h
index be71357..5eecb56 100644
--- a/testhal/STM32/STM32F4xx/FSMC_SRAM/halconf_community.h
+++ b/testhal/STM32/STM32F4xx/FSMC_SRAM/halconf_community.h
@@ -45,6 +45,13 @@
#define HAL_USE_EICU FALSE
#endif
+/**
+ * @brief Enables the CRC subsystem.
+ */
+#if !defined(HAL_USE_CRC) || defined(__DOXYGEN__)
+#define HAL_USE_CRC FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/
diff --git a/testhal/STM32/STM32F4xx/onewire/.project b/testhal/STM32/STM32F4xx/onewire/.project
index cb64a53..9b98906 100644
--- a/testhal/STM32/STM32F4xx/onewire/.project
+++ b/testhal/STM32/STM32F4xx/onewire/.project
@@ -84,7 +84,7 @@
<link>
<name>os-git</name>
<type>2</type>
- <locationURI>PARENT-5-PROJECT_LOC/os</locationURI>
+ <locationURI>PARENT-5-PROJECT_LOC/ChibiOS-RT/os</locationURI>
</link>
</linkedResources>
</projectDescription>
diff --git a/testhal/STM32/STM32F4xx/onewire/Makefile b/testhal/STM32/STM32F4xx/onewire/Makefile
index ab10921..36a1602 100644
--- a/testhal/STM32/STM32F4xx/onewire/Makefile
+++ b/testhal/STM32/STM32F4xx/onewire/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk