aboutsummaryrefslogtreecommitdiffstats
path: root/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
diff options
context:
space:
mode:
authorAndrea Zoppi <texzk@email.it>2015-06-28 22:53:44 +0200
committerAndrea Zoppi <texzk@email.it>2015-06-28 22:53:44 +0200
commit58f5fd1d72377de5a4b160bfdad0d5dd7b126875 (patch)
treef3c34085ae8a9c90cabe5c51963e336b8e04ab7a /demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
parentb872d9409ce5527125b2a313166ff3e301d76269 (diff)
downloadChibiOS-Contrib-58f5fd1d72377de5a4b160bfdad0d5dd7b126875.tar.gz
ChibiOS-Contrib-58f5fd1d72377de5a4b160bfdad0d5dd7b126875.tar.bz2
ChibiOS-Contrib-58f5fd1d72377de5a4b160bfdad0d5dd7b126875.zip
Removed dependency on ST library for SDRAM
Diffstat (limited to 'demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile')
-rw-r--r--demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile b/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
index c1fa53e..e3ff33c 100644
--- a/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
+++ b/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
@@ -90,7 +90,7 @@ CHIBIOS = ../../../..
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f4xx.mk
# HAL-OSAL files (optional).
-include $(CHIBIOS)/os/hal/hal.mk
+include $(CHIBIOS)/community/os/hal/hal.mk
include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F4xx/platform.mk
include $(CHIBIOS)/os/hal/boards/ST_STM32F429I_DISCOVERY/board.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
@@ -120,8 +120,6 @@ CSRC = $(STARTUPSRC) \
./main.c \
./wolf3d_palette.c \
./res/wolf3d_vgagraph_chunk87.c \
- ./stmdrivers/stm32f4xx_fmc.c \
- ./stmdrivers/stm32f429i_discovery_sdram.c \
# eol
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
@@ -157,7 +155,6 @@ INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(CHIBIOS)/os/hal/lib/streams \
$(CHIBIOS)/community/os/various/devices_lib/others \
./res \
- ./stmdrivers \
# eol
#