aboutsummaryrefslogtreecommitdiffstats
path: root/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
diff options
context:
space:
mode:
authorRomain Reignier <rom.reignier@gmail.com>2018-03-12 21:14:56 +0100
committerRomain Reignier <rom.reignier@gmail.com>2018-03-12 21:20:41 +0100
commitc26840fe0bc7bc5890afb13da3296ced3cc9b2cf (patch)
tree856296152dd31e88a4b40c96c0958c7c0f82deb3 /demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
parent3a9593e6d8c7fadf46b446946f4312f4a98a6914 (diff)
downloadChibiOS-Contrib-c26840fe0bc7bc5890afb13da3296ced3cc9b2cf.tar.gz
ChibiOS-Contrib-c26840fe0bc7bc5890afb13da3296ced3cc9b2cf.tar.bz2
ChibiOS-Contrib-c26840fe0bc7bc5890afb13da3296ced3cc9b2cf.zip
demos: stm32: update to latest ChibiOS API
Diffstat (limited to 'demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile')
-rw-r--r--demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile b/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
index f399710..6cf025a 100644
--- a/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
+++ b/demos/STM32/RT-STM32F429-DISCOVERY-DMA2D/Makefile
@@ -5,7 +5,7 @@
# Compiler options here.
ifeq ($(USE_OPT),)
- USE_OPT = -O0 -ggdb -fomit-frame-pointer -falign-functions=16
+ USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
endif
# C specific options here (added to USE_OPT).
@@ -30,7 +30,7 @@ endif
# Enable this if you want link time optimizations (LTO)
ifeq ($(USE_LTO),)
- USE_LTO = no
+ USE_LTO = yes
endif
# If enabled, this option allows to compile the application in THUMB mode.
@@ -99,7 +99,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+include $(CHIBIOS)/test/lib/test.mk
+include $(CHIBIOS)/test/rt/rt_test.mk
+include $(CHIBIOS)/test/oslib/oslib_test.mk
include $(CHIBIOS)/os/hal/lib/streams/streams.mk
include $(CHIBIOS)/os/various/shell/shell.mk