aboutsummaryrefslogtreecommitdiffstats
path: root/os/common/ports/ARMCMx/compilers/GCC
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-06-02 19:55:16 +0300
committerbarthess <barthess@yandex.ru>2015-06-02 19:55:16 +0300
commitfce100680ecae2d19d1c7fb05a769a1968ade733 (patch)
tree86b3c2ec9475350f36dff82b5ecc72db23c8359b /os/common/ports/ARMCMx/compilers/GCC
parente4c2e8adf8e1b7966545e01ec710575625f7c2e0 (diff)
parent06640e31ced8a273633937cbafa7b3b85c92406a (diff)
downloadChibiOS-Contrib-fce100680ecae2d19d1c7fb05a769a1968ade733.tar.gz
ChibiOS-Contrib-fce100680ecae2d19d1c7fb05a769a1968ade733.tar.bz2
ChibiOS-Contrib-fce100680ecae2d19d1c7fb05a769a1968ade733.zip
Merge branch 'master' of github.com:ChibiOS/ChibiOS-Contrib
Diffstat (limited to 'os/common/ports/ARMCMx/compilers/GCC')
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/ld/NRF51822.ld48
-rw-r--r--os/common/ports/ARMCMx/compilers/GCC/mk/startup_nrf51.mk11
2 files changed, 59 insertions, 0 deletions
diff --git a/os/common/ports/ARMCMx/compilers/GCC/ld/NRF51822.ld b/os/common/ports/ARMCMx/compilers/GCC/ld/NRF51822.ld
new file mode 100644
index 0000000..ba12060
--- /dev/null
+++ b/os/common/ports/ARMCMx/compilers/GCC/ld/NRF51822.ld
@@ -0,0 +1,48 @@
+/*
+ Copyright (C) 2015 Fabio Utzig
+
+ Licensed under the Apache License, Version 2.0 (the "License");
+ you may not use this file except in compliance with the License.
+ You may obtain a copy of the License at
+
+ http://www.apache.org/licenses/LICENSE-2.0
+
+ Unless required by applicable law or agreed to in writing, software
+ distributed under the License is distributed on an "AS IS" BASIS,
+ WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+ See the License for the specific language governing permissions and
+ limitations under the License.
+*/
+
+/*
+ * NRF51822 memory setup.
+ */
+MEMORY
+{
+ flash : org = 0x00000000, len = 256k
+ ram0 : org = 0x20000000, len = 32k
+ ram1 : org = 0x00000000, len = 0
+ ram2 : org = 0x00000000, len = 0
+ ram3 : org = 0x00000000, len = 0
+ ram4 : org = 0x00000000, len = 0
+ ram5 : org = 0x00000000, len = 0
+ ram6 : org = 0x00000000, len = 0
+ ram7 : org = 0x00000000, len = 0
+}
+
+/* RAM region to be used for Main stack. This stack accommodates the processing
+ of all exceptions and interrupts*/
+REGION_ALIAS("MAIN_STACK_RAM", ram0);
+
+/* RAM region to be used for the process stack. This is the stack used by
+ the main() function.*/
+REGION_ALIAS("PROCESS_STACK_RAM", ram0);
+
+/* RAM region to be used for data segment.*/
+REGION_ALIAS("DATA_RAM", ram0);
+
+/* RAM region to be used for BSS segment.*/
+REGION_ALIAS("BSS_RAM", ram0);
+
+
+INCLUDE rules.ld
diff --git a/os/common/ports/ARMCMx/compilers/GCC/mk/startup_nrf51.mk b/os/common/ports/ARMCMx/compilers/GCC/mk/startup_nrf51.mk
new file mode 100644
index 0000000..7433ba2
--- /dev/null
+++ b/os/common/ports/ARMCMx/compilers/GCC/mk/startup_nrf51.mk
@@ -0,0 +1,11 @@
+# List of the ChibiOS generic NRF51 startup and CMSIS files.
+STARTUPSRC = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt1.c \
+ $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/vectors.c
+
+STARTUPASM = $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/crt0_v6m.s
+
+STARTUPINC = $(CHIBIOS)/community/os/common/ports/ARMCMx/devices/NRF51822 \
+ $(CHIBIOS)/os/ext/CMSIS/include
+
+STARTUPLD = $(CHIBIOS)/community/os/common/ports/ARMCMx/compilers/GCC/ld
+