aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/boards/NRF52-DK/board.mk
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2016-07-08 19:46:51 +0200
committerStephane D'Alu <sdalu@sdalu.com>2016-07-08 19:46:51 +0200
commitddebbfc5d2ddcde8337ff5f88359770220df9f58 (patch)
tree5f4a5a92206cf2902ad6849f443344d8eb1e35d0 /os/hal/boards/NRF52-DK/board.mk
parent8306aabdfc13302edfa81c55a774ed7daefdc9c4 (diff)
downloadChibiOS-Contrib-ddebbfc5d2ddcde8337ff5f88359770220df9f58.tar.gz
ChibiOS-Contrib-ddebbfc5d2ddcde8337ff5f88359770220df9f58.tar.bz2
ChibiOS-Contrib-ddebbfc5d2ddcde8337ff5f88359770220df9f58.zip
NRF52 board
Diffstat (limited to 'os/hal/boards/NRF52-DK/board.mk')
-rw-r--r--os/hal/boards/NRF52-DK/board.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/os/hal/boards/NRF52-DK/board.mk b/os/hal/boards/NRF52-DK/board.mk
new file mode 100644
index 0000000..980fcc7
--- /dev/null
+++ b/os/hal/boards/NRF52-DK/board.mk
@@ -0,0 +1,12 @@
+# List of all the board related files.
+BOARDSRC = ${CHIBIOS_CONTRIB}/os/hal/boards/NRF52-DK/board.c
+
+# Required include directories
+BOARDINC = ${CHIBIOS_CONTRIB}/os/hal/boards/NRF52-DK
+
+# Flash
+JLINK_DEVICE = nrf52832
+#JLINK_PRE_FLASH = w4 4001e504 1
+#JLINK_ERASE_ALL = w4 4001e504 2\nw4 4001e50c 1\nsleep 100
+JLINK_PIN_RESET = w4 40000544 1\nsi 0\ntck0\nt0\nsleep 10\nt1
+