aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/KINETIS/MK66F18/platform.mk
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2018-05-07 16:58:30 +0200
committerGitHub <noreply@github.com>2018-05-07 16:58:30 +0200
commit6cc0927c068d07bb27a7bccfdb61c240771b5372 (patch)
tree9de118ea8f3e84436d7137a3122f518a057e0342 /os/hal/ports/KINETIS/MK66F18/platform.mk
parent43fb76203d6098989983d9233ba8cfe520f4f7d9 (diff)
parent619d45c0ffc02ca122f5ec7c34a1d6f82060fb7d (diff)
downloadChibiOS-Contrib-6cc0927c068d07bb27a7bccfdb61c240771b5372.tar.gz
ChibiOS-Contrib-6cc0927c068d07bb27a7bccfdb61c240771b5372.tar.bz2
ChibiOS-Contrib-6cc0927c068d07bb27a7bccfdb61c240771b5372.zip
Merge pull request #158 from walkerstop/mike
Kinetis MK66F18 and PJRC Teensy 3.6 support
Diffstat (limited to 'os/hal/ports/KINETIS/MK66F18/platform.mk')
-rw-r--r--os/hal/ports/KINETIS/MK66F18/platform.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/os/hal/ports/KINETIS/MK66F18/platform.mk b/os/hal/ports/KINETIS/MK66F18/platform.mk
new file mode 100644
index 0000000..0e6be12
--- /dev/null
+++ b/os/hal/ports/KINETIS/MK66F18/platform.mk
@@ -0,0 +1,19 @@
+# List of all platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_pal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_spi_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_i2c_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_ext_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_adc_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_sdc_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18/hal_pwm_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD/hal_usb_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/MK66F18 \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/KINETIS/LLD