aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/MSP430X/platform.mk
diff options
context:
space:
mode:
authorAndrew Wygle <awygle@gmail.com>2016-04-08 01:43:46 -0700
committerAndrew Wygle <awygle@gmail.com>2016-04-08 01:46:32 -0700
commitfd20f0fa17bfdf81dc28e7d30f13ca80264b7c78 (patch)
treeace5b24746120cea70c247b6cd723fc886e9e5b8 /os/hal/ports/MSP430X/platform.mk
parent9d74dd2661b80a5ae8598591f0251b197cc51756 (diff)
downloadChibiOS-Contrib-fd20f0fa17bfdf81dc28e7d30f13ca80264b7c78.tar.gz
ChibiOS-Contrib-fd20f0fa17bfdf81dc28e7d30f13ca80264b7c78.tar.bz2
ChibiOS-Contrib-fd20f0fa17bfdf81dc28e7d30f13ca80264b7c78.zip
Initial MSP430X Port.
This port includes hal, pal, serial, and st drivers. It supports both large and small model code and data for MSP430X-class CPUs. It has only been tested on the EXP430FR5969 LaunchPad board.
Diffstat (limited to 'os/hal/ports/MSP430X/platform.mk')
-rw-r--r--os/hal/ports/MSP430X/platform.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/os/hal/ports/MSP430X/platform.mk b/os/hal/ports/MSP430X/platform.mk
new file mode 100644
index 0000000..b0f256e
--- /dev/null
+++ b/os/hal/ports/MSP430X/platform.mk
@@ -0,0 +1,8 @@
+# List of all the MSP430X platform files.
+PLATFORMSRC = ${CHIBIOS_CONTRIB}/os/hal/ports/MSP430X/hal_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/MSP430X/hal_st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/MSP430X/hal_serial_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/MSP430X/hal_pal_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS_CONTRIB}/os/hal/ports/MSP430X