aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF5/NRF52832
diff options
context:
space:
mode:
authorStephane D'Alu <sdalu@sdalu.com>2016-07-10 19:15:46 +0200
committerStephane D'Alu <sdalu@sdalu.com>2016-07-10 19:15:46 +0200
commit321ec844af3b1e7a23c94bce65bc8aa13ef1e09e (patch)
tree1eea159a7f4fd9e8cb27d41405fbd1f719c74441 /os/hal/ports/NRF5/NRF52832
parent5d1b4d1d776f4e32b5f238a977172800417727bf (diff)
downloadChibiOS-Contrib-321ec844af3b1e7a23c94bce65bc8aa13ef1e09e.tar.gz
ChibiOS-Contrib-321ec844af3b1e7a23c94bce65bc8aa13ef1e09e.tar.bz2
ChibiOS-Contrib-321ec844af3b1e7a23c94bce65bc8aa13ef1e09e.zip
moved GPT to LLD
Diffstat (limited to 'os/hal/ports/NRF5/NRF52832')
-rw-r--r--os/hal/ports/NRF5/NRF52832/platform.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/os/hal/ports/NRF5/NRF52832/platform.mk b/os/hal/ports/NRF5/NRF52832/platform.mk
index fd3912c..57ae88d 100644
--- a/os/hal/ports/NRF5/NRF52832/platform.mk
+++ b/os/hal/ports/NRF5/NRF52832/platform.mk
@@ -12,6 +12,9 @@ endif
ifneq ($(findstring HAL_USE_SERIAL TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_serial_lld.c
endif
+ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_gpt_lld.c
+endif
ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_wdg_lld.c
endif
@@ -24,6 +27,7 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_pal_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_serial_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_st_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_gpt_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_wdg_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF5/LLD/hal_rng_lld.c
endif