aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF51/NRF51822/platform.mk
diff options
context:
space:
mode:
authorFabio Utzig <utzig@utzig.org>2016-02-09 15:21:31 -0200
committerFabio Utzig <utzig@utzig.org>2016-02-09 15:21:31 -0200
commitdb994ed1a671fe299499dc9ce0cd28cfebc2f409 (patch)
tree6c2bcaa12e6229f1dff9baa3d939e1d37c7e9ae1 /os/hal/ports/NRF51/NRF51822/platform.mk
parent5af8452153646009731c11dd92a8634695b60d55 (diff)
parentf6febd2b5a61c78610a516f60ba3da28bf653cf6 (diff)
downloadChibiOS-Contrib-db994ed1a671fe299499dc9ce0cd28cfebc2f409.tar.gz
ChibiOS-Contrib-db994ed1a671fe299499dc9ce0cd28cfebc2f409.tar.bz2
ChibiOS-Contrib-db994ed1a671fe299499dc9ce0cd28cfebc2f409.zip
Merge pull request #34 from sdalu/wdg
Watchdog
Diffstat (limited to 'os/hal/ports/NRF51/NRF51822/platform.mk')
-rw-r--r--os/hal/ports/NRF51/NRF51822/platform.mk8
1 files changed, 7 insertions, 1 deletions
diff --git a/os/hal/ports/NRF51/NRF51822/platform.mk b/os/hal/ports/NRF51/NRF51822/platform.mk
index 4fb50bc..1a4d876 100644
--- a/os/hal/ports/NRF51/NRF51822/platform.mk
+++ b/os/hal/ports/NRF51/NRF51822/platform.mk
@@ -28,6 +28,9 @@ endif
ifneq ($(findstring HAL_USE_GPT TRUE,$(HALCONF)),)
PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/gpt_lld.c
endif
+ifneq ($(findstring HAL_USE_WDG TRUE,$(HALCONF)),)
+PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/wdg_lld.c
+endif
else
PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/hal_lld.c \
@@ -39,9 +42,12 @@ PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/ext_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/i2c_lld.c \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/adc_lld.c \
- ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/gpt_lld.c
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/gpt_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822/wdg_lld.c
endif
# Required include directories
PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
${CHIBIOS_CONTRIB}/os/hal/ports/NRF51/NRF51822
+
+