aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/NRF51/NRF51822/platform.mk
diff options
context:
space:
mode:
authorFabio Utzig <utzig@utzig.org>2015-04-29 19:48:06 -0300
committerFabio Utzig <utzig@utzig.org>2015-04-29 19:48:06 -0300
commite07ebbcac3f9a6bf871ad23b4c6cd0eb0d72809e (patch)
treebe7d85d6be4759068d68c80b12178cfd58c2e552 /os/hal/ports/NRF51/NRF51822/platform.mk
parent7ea6fb8e07471c01ca67291c22c6f49fbcf70570 (diff)
downloadChibiOS-Contrib-e07ebbcac3f9a6bf871ad23b4c6cd0eb0d72809e.tar.gz
ChibiOS-Contrib-e07ebbcac3f9a6bf871ad23b4c6cd0eb0d72809e.tar.bz2
ChibiOS-Contrib-e07ebbcac3f9a6bf871ad23b4c6cd0eb0d72809e.zip
Add initial system header + makefile
Diffstat (limited to 'os/hal/ports/NRF51/NRF51822/platform.mk')
-rw-r--r--os/hal/ports/NRF51/NRF51822/platform.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/os/hal/ports/NRF51/NRF51822/platform.mk b/os/hal/ports/NRF51/NRF51822/platform.mk
new file mode 100644
index 0000000..5e8588d
--- /dev/null
+++ b/os/hal/ports/NRF51/NRF51822/platform.mk
@@ -0,0 +1,8 @@
+# List of all the NRF51x platform files.
+PLATFORMSRC = ${CHIBIOS}/os/hal/ports/common/ARMCMx/nvic.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/hal_lld.c \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822/pal_lld.c
+
+# Required include directories
+PLATFORMINC = ${CHIBIOS}/os/hal/ports/common/ARMCMx \
+ ${CHIBIOS}/community/os/hal/ports/NRF51/NRF51822