aboutsummaryrefslogtreecommitdiffstats
path: root/os/hal/ports/STM32/STM32F7xx/platform.mk
diff options
context:
space:
mode:
authorMichael Walker <walkerstop@gmail.com>2018-05-02 03:33:23 -0700
committerMichael Walker <walkerstop@gmail.com>2018-05-02 03:33:23 -0700
commit6d879f58f5b56eda3330aa6e7f8382f441adecf4 (patch)
treedad3f1f3b6ac3927484ee22002a947662a8a0173 /os/hal/ports/STM32/STM32F7xx/platform.mk
parent4e9f077fb10255dced1da4d5d2ad9f8ae41442a2 (diff)
parentd4d384557df0e8e7a8071553448b0c42849f98c0 (diff)
downloadChibiOS-Contrib-6d879f58f5b56eda3330aa6e7f8382f441adecf4.tar.gz
ChibiOS-Contrib-6d879f58f5b56eda3330aa6e7f8382f441adecf4.tar.bz2
ChibiOS-Contrib-6d879f58f5b56eda3330aa6e7f8382f441adecf4.zip
Merge remote-tracking branch 'upstream/master'
Diffstat (limited to 'os/hal/ports/STM32/STM32F7xx/platform.mk')
-rw-r--r--os/hal/ports/STM32/STM32F7xx/platform.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/os/hal/ports/STM32/STM32F7xx/platform.mk b/os/hal/ports/STM32/STM32F7xx/platform.mk
new file mode 100644
index 0000000..2f9392f
--- /dev/null
+++ b/os/hal/ports/STM32/STM32F7xx/platform.mk
@@ -0,0 +1,9 @@
+include ${CHIBIOS}/os/hal/ports/STM32/STM32F7xx/platform.mk
+
+PLATFORMSRC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_fsmc.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_nand_lld.c \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1/hal_fsmc_sram.c \
+ ${CHIBIOS_CONTRIB}/os/hal/src/hal_fsmc_sdram.c
+
+PLATFORMINC += ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD/FSMCv1 \
+ ${CHIBIOS_CONTRIB}/os/hal/ports/STM32/LLD