aboutsummaryrefslogtreecommitdiffstats
path: root/os
diff options
context:
space:
mode:
authormarcoveeneman <marco-veeneman@hotmail.com>2018-03-02 00:02:48 +0100
committermarcoveeneman <marco-veeneman@hotmail.com>2018-03-02 00:02:48 +0100
commitff7d474ecd9fbf9d0aba0a9eeb9ac6e26c8d033b (patch)
tree98226f556bcb31bf822924727c7a8c2cda98a418 /os
parent927b3cf1b4e00ef1c0fc31fb46f2db1c909ecde8 (diff)
downloadChibiOS-Contrib-ff7d474ecd9fbf9d0aba0a9eeb9ac6e26c8d033b.tar.gz
ChibiOS-Contrib-ff7d474ecd9fbf9d0aba0a9eeb9ac6e26c8d033b.tar.bz2
ChibiOS-Contrib-ff7d474ecd9fbf9d0aba0a9eeb9ac6e26c8d033b.zip
Updated platform.mk files to handle halconf.h files located in CONFDIR
Diffstat (limited to 'os')
-rw-r--r--os/hal/ports/TIVA/TM4C123x/platform.mk9
-rw-r--r--os/hal/ports/TIVA/TM4C129x/platform.mk9
2 files changed, 16 insertions, 2 deletions
diff --git a/os/hal/ports/TIVA/TM4C123x/platform.mk b/os/hal/ports/TIVA/TM4C123x/platform.mk
index de482d0..8372c25 100644
--- a/os/hal/ports/TIVA/TM4C123x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C123x/platform.mk
@@ -7,7 +7,14 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C123x
ifeq ($(USE_SMART_BUILD),yes)
-HALCONF := $(strip $(shell cat halconf.h | egrep -e "\#define"))
+
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
+else
endif
# Drivers compatible with the platform.
diff --git a/os/hal/ports/TIVA/TM4C129x/platform.mk b/os/hal/ports/TIVA/TM4C129x/platform.mk
index 8e4c9fa..934a6c2 100644
--- a/os/hal/ports/TIVA/TM4C129x/platform.mk
+++ b/os/hal/ports/TIVA/TM4C129x/platform.mk
@@ -7,7 +7,14 @@ PLATFORMINC := $(CHIBIOS)/os/hal/ports/common/ARMCMx \
${CHIBIOS_CONTRIB}/os/hal/ports/TIVA/TM4C129x
ifeq ($(USE_SMART_BUILD),yes)
-HALCONF := $(strip $(shell cat halconf.h | egrep -e "\#define"))
+
+# Configuration files directory
+ifeq ($(CONFDIR),)
+ CONFDIR = .
+endif
+
+HALCONF := $(strip $(shell cat $(CONFDIR)/halconf.h | egrep -e "\#define"))
+else
endif
# Drivers compatible with the platform.