aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/MSP430X/EXP430FR5969/DMA/Makefile
diff options
context:
space:
mode:
authorAndrew Wygle <awygle@gmail.com>2016-05-07 23:35:10 -0700
committerAndrew Wygle <awygle@gmail.com>2016-05-08 17:59:09 -0700
commitdfd93d512b6703ac45d5c0e322bcf8b5e83f50f1 (patch)
tree7a4c49a2e3852905297b85e1452071b1c876cfaa /testhal/MSP430X/EXP430FR5969/DMA/Makefile
parentcf02c79b5aa7209542cbf1b0cefe703a2c0c60be (diff)
downloadChibiOS-Contrib-dfd93d512b6703ac45d5c0e322bcf8b5e83f50f1.tar.gz
ChibiOS-Contrib-dfd93d512b6703ac45d5c0e322bcf8b5e83f50f1.tar.bz2
ChibiOS-Contrib-dfd93d512b6703ac45d5c0e322bcf8b5e83f50f1.zip
Added SPI driver and test code to MSP430X port
A DMA-driven SPI driver and fairly comprehensive test code for SPI on the MSP430X port. Required some cleanup to the DMA and Serial drivers as well. Includes some reformatting to be more in line with ChibiOS coding standards.
Diffstat (limited to 'testhal/MSP430X/EXP430FR5969/DMA/Makefile')
-rw-r--r--testhal/MSP430X/EXP430FR5969/DMA/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/testhal/MSP430X/EXP430FR5969/DMA/Makefile b/testhal/MSP430X/EXP430FR5969/DMA/Makefile
index e109c95..cf81f18 100644
--- a/testhal/MSP430X/EXP430FR5969/DMA/Makefile
+++ b/testhal/MSP430X/EXP430FR5969/DMA/Makefile
@@ -113,7 +113,6 @@ include $(CHIBIOS)/os/hal/osal/nil/osal.mk
include $(CHIBIOS)/os/nil/nil.mk
include $(CHIBIOS_CONTRIB)/os/common/ports/MSP430X/compilers/GCC/mk/port.mk
# Other files (optional).
-include $(CHIBIOS)/test/nil/test.mk
# Define linker script file here
LDSCRIPT = $(STARTUPLD)/msp430fr5969.ld