aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/NRF51/NRF51822/PWM/Makefile
diff options
context:
space:
mode:
authorKonstantin Oblaukhov <oblaukhov.konstantin@gmail.com>2018-09-29 18:08:56 +0700
committerKonstantin K. Oblaukhov <oblaukhov.konstantin@gmail.com>2018-11-20 09:52:42 +0700
commit0e6f501f80d590a7f79b3b4b3f4ec278df57ad40 (patch)
treef795d5584ff5aa805fd2a1a81d224076788a4253 /testhal/NRF51/NRF51822/PWM/Makefile
parentf4d6d909898e777efaa2d479095e41cd2045621d (diff)
downloadChibiOS-Contrib-0e6f501f80d590a7f79b3b4b3f4ec278df57ad40.tar.gz
ChibiOS-Contrib-0e6f501f80d590a7f79b3b4b3f4ec278df57ad40.tar.bz2
ChibiOS-Contrib-0e6f501f80d590a7f79b3b4b3f4ec278df57ad40.zip
Update all NRF5x makefiles and chconf.h.
Add missing halconf_community.h
Diffstat (limited to 'testhal/NRF51/NRF51822/PWM/Makefile')
-rw-r--r--testhal/NRF51/NRF51822/PWM/Makefile25
1 files changed, 10 insertions, 15 deletions
diff --git a/testhal/NRF51/NRF51822/PWM/Makefile b/testhal/NRF51/NRF51822/PWM/Makefile
index de6ba9f..cc7bc1b 100644
--- a/testhal/NRF51/NRF51822/PWM/Makefile
+++ b/testhal/NRF51/NRF51822/PWM/Makefile
@@ -91,6 +91,8 @@ CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS_CONTRIB)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_nrf51.mk
+# Licensing files.
+include $(CHIBIOS)/os/license/license.mk
# HAL-OSAL files (optional).
include $(CHIBIOS)/os/hal/hal.mk
include $(CHIBIOS_CONTRIB)/os/hal/ports/NRF5/NRF51822/platform.mk
@@ -100,25 +102,20 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk
include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v6m.mk
# Other files (optional).
-include $(CHIBIOS)/test/rt/test.mk
+#include $(CHIBIOS)/test/rt/test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/NRF51822.ld
# C sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CSRC = $(STARTUPSRC) \
- $(KERNSRC) \
- $(PORTSRC) \
- $(OSALSRC) \
- $(HALSRC) \
- $(PLATFORMSRC) \
- $(BOARDSRC) \
+CSRC = $(ALLCSRC) \
+ $(TESTSRC) \
main.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
-CPPSRC =
+CPPSRC = $(ALLCPPSRC)
# C sources to be compiled in ARM mode regardless of the global setting.
# NOTE: Mixing ARM and THUMB mode enables the -mthumb-interwork compiler
@@ -141,13 +138,11 @@ TCSRC =
TCPPSRC =
# List ASM source files here
-ASMSRC =
-ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
+ASMSRC = $(ALLASMSRC)
+ASMXSRC = $(ALLXASMSRC)
-INCDIR = $(CHIBIOS)/os/license \
- $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
- $(HALINC) $(PLATFORMINC) $(BOARDINC) \
- $(CHIBIOS)/os/various $(CHIBIOS)/os/license
+INCDIR = $(ALLINC) $(TESTINC) \
+ $(TESTHAL)
#
# Project, sources and paths