diff options
author | barthess <barthess@yandex.ru> | 2016-10-18 12:02:55 +0300 |
---|---|---|
committer | barthess <barthess@yandex.ru> | 2016-10-18 12:02:55 +0300 |
commit | 555f301da2f276cc353a8e2d0a283a488bd8eeff (patch) | |
tree | 2ae51b49dec5bf94ef79ea97a66a263a2aef7b88 /testhal/STM32/STM32F0xx/onewire/Makefile | |
parent | bd47894d622acbc18bf99b0b46bf7b0ed7330634 (diff) | |
download | ChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.tar.gz ChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.tar.bz2 ChibiOS-Contrib-555f301da2f276cc353a8e2d0a283a488bd8eeff.zip |
1-Wire. Duplicated code from testhal apllications moved to separate directory.
Diffstat (limited to 'testhal/STM32/STM32F0xx/onewire/Makefile')
-rw-r--r-- | testhal/STM32/STM32F0xx/onewire/Makefile | 6 |
1 files changed, 4 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F0xx/onewire/Makefile b/testhal/STM32/STM32F0xx/onewire/Makefile index d121cee..e866cb2 100644 --- a/testhal/STM32/STM32F0xx/onewire/Makefile +++ b/testhal/STM32/STM32F0xx/onewire/Makefile @@ -77,6 +77,7 @@ PROJECT = ch # Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
+TESTHAL = $(CHIBIOS_CONTRIB)/testhal/hw_abstracted/onewire
# Startup files.
include $(CHIBIOS)/os/common/startup/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
# HAL-OSAL files (optional).
@@ -102,7 +103,7 @@ CSRC = $(STARTUPSRC) \ $(BOARDSRC) \
$(TESTSRC) \
main.c \
- onewire_test.c
+ $(TESTHAL)/testhal_onewire.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
@@ -135,7 +136,8 @@ ASMXSRC = $(STARTUPASM) $(PORTASM) $(OSALASM) INCDIR = $(CHIBIOS)/os/license \
$(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various
+ $(CHIBIOS)/os/various \
+ $(TESTHAL)
#
# Project, sources and paths
|