aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F0xx/onewire
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-06-28 22:22:01 +0300
committerbarthess <barthess@yandex.ru>2015-06-28 22:22:01 +0300
commit4e98ee4b123bddd22448fef47e02009428bb5f41 (patch)
tree7b39f421131cd62e006efae8824e598690fe1e36 /testhal/STM32/STM32F0xx/onewire
parentb7ca6b32d079fb689ab2ac588f8b93d6d8e660b2 (diff)
downloadChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.tar.gz
ChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.tar.bz2
ChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.zip
Added -Wundef key into Makefiles
Diffstat (limited to 'testhal/STM32/STM32F0xx/onewire')
-rw-r--r--testhal/STM32/STM32F0xx/onewire/Makefile2
-rw-r--r--testhal/STM32/STM32F0xx/onewire/halconf.h7
-rw-r--r--testhal/STM32/STM32F0xx/onewire/halconf_community.h7
3 files changed, 15 insertions, 1 deletions
diff --git a/testhal/STM32/STM32F0xx/onewire/Makefile b/testhal/STM32/STM32F0xx/onewire/Makefile
index 72acaf4..1d47242 100644
--- a/testhal/STM32/STM32F0xx/onewire/Makefile
+++ b/testhal/STM32/STM32F0xx/onewire/Makefile
@@ -170,7 +170,7 @@ AOPT =
TOPT = -mthumb -DTHUMB
# Define C warning options here
-CWARN = -Wall -Wextra -Wstrict-prototypes
+CWARN = -Wall -Wextra -Wstrict-prototypes -Wundef
# Define C++ warning options here
CPPWARN = -Wall -Wextra
diff --git a/testhal/STM32/STM32F0xx/onewire/halconf.h b/testhal/STM32/STM32F0xx/onewire/halconf.h
index b0151c3..cf2b3f6 100644
--- a/testhal/STM32/STM32F0xx/onewire/halconf.h
+++ b/testhal/STM32/STM32F0xx/onewire/halconf.h
@@ -45,6 +45,13 @@
#endif
/**
+ * @brief Enables the DAC subsystem.
+ */
+#if !defined(HAL_USE_DAC) || defined(__DOXYGEN__)
+#define HAL_USE_DAC FALSE
+#endif
+
+/**
* @brief Enables the CAN subsystem.
*/
#if !defined(HAL_USE_CAN) || defined(__DOXYGEN__)
diff --git a/testhal/STM32/STM32F0xx/onewire/halconf_community.h b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
index 7f037ec..e90257b 100644
--- a/testhal/STM32/STM32F0xx/onewire/halconf_community.h
+++ b/testhal/STM32/STM32F0xx/onewire/halconf_community.h
@@ -38,6 +38,13 @@
#define HAL_USE_ONEWIRE TRUE
#endif
+/**
+ * @brief Enables the EICU subsystem.
+ */
+#if !defined(HAL_USE_EICU) || defined(__DOXYGEN__)
+#define HAL_USE_EICU FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/