aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F0xx
diff options
context:
space:
mode:
authorFabien Poussin <fabien.poussin@gmail.com>2015-08-20 17:47:21 +0200
committerFabien Poussin <fabien.poussin@gmail.com>2015-08-20 17:47:21 +0200
commit48a03708ff6ed34e7b0576e2c2b36587e58779d8 (patch)
tree84a8d07351e63cef2f1bada79ff160e13bf93562 /testhal/STM32/STM32F0xx
parent3a945458c067f0fb2aeefd22ac928fe982da6c3a (diff)
downloadChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.tar.gz
ChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.tar.bz2
ChibiOS-Contrib-48a03708ff6ed34e7b0576e2c2b36587e58779d8.zip
Changed the way files are included to a more convenient way.
Diffstat (limited to 'testhal/STM32/STM32F0xx')
-rw-r--r--testhal/STM32/STM32F0xx/crc/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/testhal/STM32/STM32F0xx/crc/Makefile b/testhal/STM32/STM32F0xx/crc/Makefile
index 835f072..d04a56a 100644
--- a/testhal/STM32/STM32F0xx/crc/Makefile
+++ b/testhal/STM32/STM32F0xx/crc/Makefile
@@ -81,12 +81,13 @@ endif
PROJECT = ch
# Imported source files and paths
-CHIBIOS = ../../../../..
+CHIBIOS = ../../../../../ChibiOS-RT
+CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f0xx.mk
# HAL-OSAL files (optional).
-include $(CHIBIOS)/community/os/hal/hal.mk
-include $(CHIBIOS)/community/os/hal/ports/STM32/STM32F0xx/platform.mk
+include $(CHIBIOS_CONTRIB)/os/hal/hal.mk
+include $(CHIBIOS_CONTRIB)/os/hal/ports/STM32/STM32F0xx/platform.mk
include $(CHIBIOS)/os/hal/boards/ST_STM32F072B_DISCOVERY/board.mk
include $(CHIBIOS)/os/hal/osal/rt/osal.mk
# RTOS files (optional).
@@ -109,7 +110,7 @@ CSRC = $(STARTUPSRC) \
$(BOARDSRC) \
$(TESTSRC) \
main.c \
- $(CHIBIOS)/community/os/various/crcsw.c
+ $(CHIBIOS_CONTRIB)/os/various/crcsw.c
# C++ sources that can be compiled in ARM or THUMB mode depending on the global
# setting.
@@ -140,7 +141,7 @@ ASMSRC = $(STARTUPASM) $(PORTASM) $(OSALASM)
INCDIR = $(STARTUPINC) $(KERNINC) $(PORTINC) $(OSALINC) \
$(HALINC) $(PLATFORMINC) $(BOARDINC) $(TESTINC) \
- $(CHIBIOS)/os/various $(CHIBIOS)/community/os/various
+ $(CHIBIOS)/os/various $(CHIBIOS_CONTRIB)/os/various
#
# Project, sources and paths