aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F1xx/onewire/Makefile
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-06-28 22:22:01 +0300
committerbarthess <barthess@yandex.ru>2015-06-28 22:22:01 +0300
commit4e98ee4b123bddd22448fef47e02009428bb5f41 (patch)
tree7b39f421131cd62e006efae8824e598690fe1e36 /testhal/STM32/STM32F1xx/onewire/Makefile
parentb7ca6b32d079fb689ab2ac588f8b93d6d8e660b2 (diff)
downloadChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.tar.gz
ChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.tar.bz2
ChibiOS-Contrib-4e98ee4b123bddd22448fef47e02009428bb5f41.zip
Added -Wundef key into Makefiles
Diffstat (limited to 'testhal/STM32/STM32F1xx/onewire/Makefile')
-rw-r--r--testhal/STM32/STM32F1xx/onewire/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/testhal/STM32/STM32F1xx/onewire/Makefile b/testhal/STM32/STM32F1xx/onewire/Makefile
index 8875fd8..4e33419 100644
--- a/testhal/STM32/STM32F1xx/onewire/Makefile
+++ b/testhal/STM32/STM32F1xx/onewire/Makefile
@@ -175,10 +175,10 @@ AOPT =
TOPT = -mthumb -DTHUMB
# Define C warning options here
-CWARN = -Wall -Wextra -Wstrict-prototypes
+CWARN = -Wall -Wextra -Wstrict-prototypes -Wundef
# Define C++ warning options here
-CPPWARN = -Wall -Wextra
+CPPWARN = -Wall -Wextra -Wundef
#
# Compiler settings