aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F1xx/onewire
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2014-12-09 11:31:46 +0300
committerbarthess <barthess@yandex.ru>2014-12-14 14:14:45 +0300
commit99505cdea68069a3873e670ccc95cdc0f94d2319 (patch)
treee85759dd4b3b806544b19196233d917f6265a2f1 /testhal/STM32/STM32F1xx/onewire
parent97be1351afc84c9b1cef5c89f6c04013a0709cb1 (diff)
downloadChibiOS-Contrib-99505cdea68069a3873e670ccc95cdc0f94d2319.tar.gz
ChibiOS-Contrib-99505cdea68069a3873e670ccc95cdc0f94d2319.tar.bz2
ChibiOS-Contrib-99505cdea68069a3873e670ccc95cdc0f94d2319.zip
1-wire. Added workaround form F1xx MCUs
Diffstat (limited to 'testhal/STM32/STM32F1xx/onewire')
-rw-r--r--testhal/STM32/STM32F1xx/onewire/Makefile2
-rw-r--r--testhal/STM32/STM32F1xx/onewire/onewire_test.c4
2 files changed, 3 insertions, 3 deletions
diff --git a/testhal/STM32/STM32F1xx/onewire/Makefile b/testhal/STM32/STM32F1xx/onewire/Makefile
index d657cdc..dbaaca5 100644
--- a/testhal/STM32/STM32F1xx/onewire/Makefile
+++ b/testhal/STM32/STM32F1xx/onewire/Makefile
@@ -5,7 +5,7 @@
# Compiler options here.
ifeq ($(USE_OPT),)
- USE_OPT = -O2 -ggdb -fomit-frame-pointer -falign-functions=16
+ USE_OPT = -O0 -ggdb -fomit-frame-pointer -falign-functions=16
endif
# C specific options here (added to USE_OPT).
diff --git a/testhal/STM32/STM32F1xx/onewire/onewire_test.c b/testhal/STM32/STM32F1xx/onewire/onewire_test.c
index 139732d..3ce31dc 100644
--- a/testhal/STM32/STM32F1xx/onewire/onewire_test.c
+++ b/testhal/STM32/STM32F1xx/onewire/onewire_test.c
@@ -40,8 +40,8 @@
#define GPIOB_ONEWIRE 8
#define search_led_off() (palClearPad(GPIOC, GPIOC_LED))
#define search_led_on() (palSetPad(GPIOC, GPIOC_LED))
-#define ONEWIRE_MASTER_CHANNEL 3
-#define ONEWIRE_SAMPLE_CHANNEL 2
+#define ONEWIRE_MASTER_CHANNEL 2
+#define ONEWIRE_SAMPLE_CHANNEL 3
#else
#define GPIOB_ONEWIRE GPIOB_TACHOMETER
#include "pads.h"