aboutsummaryrefslogtreecommitdiffstats
path: root/testhal/STM32/STM32F1xx
diff options
context:
space:
mode:
authorbarthess <barthess@yandex.ru>2015-08-24 16:26:22 +0300
committerbarthess <barthess@yandex.ru>2015-08-24 16:26:22 +0300
commit74065b233afc62203edcb68f281da5839dad5930 (patch)
tree7c9464bbacf5c5d429069396f47799164a48f01b /testhal/STM32/STM32F1xx
parentc7b566b9e0c376e4caacacb2e68b072a77b42deb (diff)
downloadChibiOS-Contrib-74065b233afc62203edcb68f281da5839dad5930.tar.gz
ChibiOS-Contrib-74065b233afc62203edcb68f281da5839dad5930.tar.bz2
ChibiOS-Contrib-74065b233afc62203edcb68f281da5839dad5930.zip
Fixed rest of paths in build scripts.
Diffstat (limited to 'testhal/STM32/STM32F1xx')
-rw-r--r--testhal/STM32/STM32F1xx/onewire/Makefile1
-rw-r--r--testhal/STM32/STM32F1xx/onewire/chconf.h4
-rw-r--r--testhal/STM32/STM32F1xx/onewire/halconf_community.h7
3 files changed, 9 insertions, 3 deletions
diff --git a/testhal/STM32/STM32F1xx/onewire/Makefile b/testhal/STM32/STM32F1xx/onewire/Makefile
index 31a3162..1484a28 100644
--- a/testhal/STM32/STM32F1xx/onewire/Makefile
+++ b/testhal/STM32/STM32F1xx/onewire/Makefile
@@ -81,7 +81,6 @@ PROJECT = ch
# Imported source files and paths
CHIBIOS = ../../../../../ChibiOS-RT
-CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib/ChibiOS-RT
CHIBIOS_CONTRIB = $(CHIBIOS)/../ChibiOS-Contrib
# Startup files.
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/startup_stm32f1xx.mk
diff --git a/testhal/STM32/STM32F1xx/onewire/chconf.h b/testhal/STM32/STM32F1xx/onewire/chconf.h
index 5ff6e07..e714890 100644
--- a/testhal/STM32/STM32F1xx/onewire/chconf.h
+++ b/testhal/STM32/STM32F1xx/onewire/chconf.h
@@ -46,7 +46,7 @@
* @details Frequency of the system timer that drives the system ticks. This
* setting also defines the system tick time unit.
*/
-#define CH_CFG_ST_FREQUENCY 10000
+#define CH_CFG_ST_FREQUENCY 1000
/**
* @brief Time delta constant for the tick-less mode.
@@ -56,7 +56,7 @@
* The value one is not valid, timeouts are rounded up to
* this value.
*/
-#define CH_CFG_ST_TIMEDELTA 2
+#define CH_CFG_ST_TIMEDELTA 0
/** @} */
diff --git a/testhal/STM32/STM32F1xx/onewire/halconf_community.h b/testhal/STM32/STM32F1xx/onewire/halconf_community.h
index e90257b..6c628c0 100644
--- a/testhal/STM32/STM32F1xx/onewire/halconf_community.h
+++ b/testhal/STM32/STM32F1xx/onewire/halconf_community.h
@@ -45,6 +45,13 @@
#define HAL_USE_EICU FALSE
#endif
+/**
+ * @brief Enables the community subsystem.
+ */
+#if !defined(HAL_USE_CRC) || defined(__DOXYGEN__)
+#define HAL_USE_CRC FALSE
+#endif
+
/*===========================================================================*/
/* FSMCNAND driver related settings. */
/*===========================================================================*/