diff options
author | Romain Reignier <rom.reignier@gmail.com> | 2018-03-12 21:18:36 +0100 |
---|---|---|
committer | Romain Reignier <rom.reignier@gmail.com> | 2018-03-12 21:20:46 +0100 |
commit | 6c3554ef8152e48e9ef668cfa321f7c7e01f5361 (patch) | |
tree | 94ad8aa3db171599f77c7b1369cd47edf005e727 /testhal/STM32/STM32F3xx/COMP/Makefile | |
parent | 6ca20973e2889ce228b41c47231a5339d8e95970 (diff) | |
download | ChibiOS-Contrib-6c3554ef8152e48e9ef668cfa321f7c7e01f5361.tar.gz ChibiOS-Contrib-6c3554ef8152e48e9ef668cfa321f7c7e01f5361.tar.bz2 ChibiOS-Contrib-6c3554ef8152e48e9ef668cfa321f7c7e01f5361.zip |
testhal: stm32: update to latest ChibiOS API
Diffstat (limited to 'testhal/STM32/STM32F3xx/COMP/Makefile')
-rw-r--r-- | testhal/STM32/STM32F3xx/COMP/Makefile | 8 |
1 files changed, 5 insertions, 3 deletions
diff --git a/testhal/STM32/STM32F3xx/COMP/Makefile b/testhal/STM32/STM32F3xx/COMP/Makefile index 90ada53..e19b2ee 100644 --- a/testhal/STM32/STM32F3xx/COMP/Makefile +++ b/testhal/STM32/STM32F3xx/COMP/Makefile @@ -10,7 +10,7 @@ endif # C specific options here (added to USE_OPT).
ifeq ($(USE_COPT),)
- USE_COPT =
+ USE_COPT =
endif
# C++ specific options here (added to USE_OPT).
@@ -69,7 +69,7 @@ ifeq ($(USE_EXCEPTIONS_STACKSIZE),) USE_EXCEPTIONS_STACKSIZE = 0x400
endif
-# Enables the use of FPU on Cortex-M4 (no, softfp, hard).
+# Enables the use of FPU (no, softfp, hard).
ifeq ($(USE_FPU),)
USE_FPU = no
endif
@@ -99,7 +99,9 @@ include $(CHIBIOS)/os/hal/osal/rt/osal.mk include $(CHIBIOS)/os/rt/rt.mk
include $(CHIBIOS)/os/common/ports/ARMCMx/compilers/GCC/mk/port_v7m.mk
# Other files (optional).
-#include $(CHIBIOS)/test/rt/test.mk
+#include $(CHIBIOS)/test/lib/test.mk
+#include $(CHIBIOS)/test/rt/rt_test.mk
+#include $(CHIBIOS)/test/oslib/oslib_test.mk
# Define linker script file here
LDSCRIPT= $(STARTUPLD)/STM32F303xC.ld
|